Tracks Listing - Artist Displayed is Album Artist not Track Artist

Hi, When go to the Tracks list it lists the Album Artist not the track artist

This is no use when the album artist is Various Artists. Is there a way to change this?

Thanks, Kel

5 Likes

I have this exact same issue. I have many albums where the album artist is “various” but the metadata also has the track artist. In other music player software I can select between the two, even the much maligned iTunes will allow you to sort on the artists within “various artists” albums.

Can the artist column be switched to the track artists rather than album artists in the sort view?

(and why has nobody responded to Kel in the last month??!)

Same issue, Jan 2018

You should be able to enable the Artist column from the dropdown at right: