Tracks on album identified as one track?


I love Roon, especially after the upgrade to 1.3.

I have one issue, which I cannot find how to solve. Some albums are seen as one continuous track and not as individual ones. Sometimes it is one work, but most of the time it isn’t like in the below example (soundtrack for Solaris). With the radio function or when in shuffle mode, the album is played completely and not one track.

Is it possible to edit into seperate tracks? And if so, how? Do I have to change something in the tags?



I have the same issue. Been listening to Badalamenti’s soundtrack for Twin Peaks and I’ve encountered this earlier with Morricone’s The Mission.

Searched the KB and did a few searches of the forum but can’t find how to edit an album’s metadata for those albums that I want to display track numbers and track names in the queue.

Can anyone help?

Indeed, I have this also with the soundtrack of Twin Peaks.

Would be nice if we could solve this!

Anyone @support knows how to adress this?

The best way is to edit your metadata in the audio files. @mtimmans I think in your case the TITLE tag for each track looks something like this Solaris, film score: [track title] . Try to remove Solaris, film score: or other text which is consistent across all the titles.
If your media files are located in the network folder, after metadata edits, I suggest to rescan the folder so Roon could notice the changes.

Thanks for your reply @vova

I have already checked this, sorry I didn’t mention that earlier.

In the tags of the files this is not the case; I have only put in basic tag information and the title tag only specifies the title of the song (so no prefix, like “Solaris, film score” or something like that).

In Roon however, this is identified in the way you specify (so title tag is: “Solaris, film score: track title”). I have already tried to change this in Roon as well as directly edit as well as per the option “prefer file tag”. Both have no impact unfortunately. It keeps seeing the tracks as one continuous track.

@mtimmans Hi Michel, I’m not sure if you saw, but new editing features have been added into Roon which will allow you to un-group these tracks.

You will need to add COMPOSITION and PART tags to your files for this album. My suggestion is to copy the track TITLE tag into a new COMPOSITION TAG, then create PART tags all containing the value “1”.

Then you’ll need to tell Roon to prefer file metadata for composition/part grouping for the album:

Please note that Roon is currently displaying the tracks as our metadata provider intended, i.e. as a multi-part work. This is a consistent editorial policy for film soundtracks and musical scores. However, you are of course completely within your rights to change this; the new editing functionality allows you to do so.

Thanks @joel for the feedback. I will try to check this solution.

It is not that I think that the way Roon is presenting the album is wrong! When playing the complete album or playing one track from the album everything is okay. Only when playing a genre (shuffle/random), the complete album is considered as one track which defeats the purpose of shuffle/random in my opinion.

This editing is, however, very welcome to avoid this! I will report back after adjusting and checking.

1 Like

@joel I can confirm that this solution works. Thanks for your help!

1 Like