Tracks skipping when playing from Qobuz

Core Machine
Windows 10, Intel i7-4770 3.40 GHz processor, Roon database stored on 120Gb external SSD, connected by USB 3.0, Roon build 795

Network Details
1 Gb Ethernet connection, Linksys MX5300 router, Internet provided by Comcast

Audio Devices
BlueSound Node 2i, connected via 1 Gb Ethernet
Library stored on LaCie NetworkSpace 2 NAS, connected via 1 Gb Ethernet

Library Size
1206 albums, 16237 tracks

Description of Issue
Like others have reported, I am experiencing skipping while listening to tracks from Qobuz. Tracks play just a few seconds, and then the next one starts. There is no stuttering or hesitation; the first track stops and the next one starts, only to play a few seconds before it stops too.

I can play tracks from my local storage without any problems. I can also play Qobuz without problem using the BluOS Controller app on my desktop PC to talk to the Node 2i. I haven’t tried Live Radio through Roon to see what happens there.

I’m running the Roon app on my desktop Windows 10 PC.

I can’t say for certain that this is associated with build 795, but it just started happening about two weeks ago, more or less the time when I upgraded to 795.

Hi @RainInTheWoods

Just to confirm, is your Core connected via Ethernet or Wifi? If Wifi, are you able to try Ethernet?

If you play to System Output do you see this problem as well?

As a test, can you go to Settings > Services and lower the streaming quality to the lowest setting? Is there any change?


A post was split to a new topic: Tracks skipping after a few seconds when playing from Qobuz

Hi @RainInTheWoods
I had these same issues from the introduction of build 790. It got so bad that I would remove Qobuz tracks from playlists. I was working with Support but had not found a solution until I came across another thread where @beka in support suggested changing the design. She listed 3 options and after doing some research I chose Cloudflare. It has been over a week and there has not been a single skip. It is wonderful to have Roon back again. Maybe this would help you as well.

1 Like

Hi @dylan, thanks for the response. My Core is connected via Ethernet.

When I tried playing to System Output just now, it rapidly skipped through each track without playing anything.

Right now I am playing Qobuz using the lowest quality setting (MP3), and I’m not experiencing skipping. Of course, high quality output is part of the point, so this isn’t a good long-term solution.

Hi @Ben_Bennett, thanks for the tip, I will give it a try tomorrow.

I am still experiencing skipping, even at the lowest quality level, although not as frequently as at higher quality levels.

I reset my DNS to use Cloudflare, but that hasn’t made a difference.

Anything else we can do?

It appears that I have a resolution for this. It may have been a flaky network switch. I noticed when I plugged my Roon Core PC into a different switch, the skipping went away. The bad switch is working well enough for data tasks, but Roon was sensitive to whatever the problem was. I’ve just replaced the bad switch.