Tracks View Default Sort

Core Machine (Operating system/System info/Roon build number)
Version: 1.7 build 571
OS Version: Linux 4.4.0-184-generic

Description Of Issue

The default sort in the Tracks view resets to Album Artist even if it’s disabled when opening up a control app. If I then sort by Artist, the Album Artist column disappears without me disabling it. Tested with Windows and Android.

Am I stuck sorting a column I don’t want by default?

Thanks for letting us know, @bdulude — We are looking into this.

Hello @bdulude and thanks for your report! I’d like to test this with you and get a report over to our QA team but I’m having issues reproducing your results. Here’s what I’ve tried:

  1. Went into “Tracks View”, enabled “Artists” column
  2. Clicked to sort by “Artists” column, and “Album Artist” didn’t disappear
  3. Clicked out of “Tracks View” and back in, no difference.
  4. Sorted by “Album Artist” worked as expected
  5. Repeated above with “Album Artist” disabled
  6. Repeated with sorting by other columns

If there’s a step I missed or something I’m not understanding please let me know! Also, have you rebooted since this issues started? How long has it been going on?

You aren’t closing the control app. Disable album artist and enable artist, then close the app and reopen it.

Restarting the core doesn’t change anything. I’ve been dealing with this ever since I disabled album artist however many months ago, probably 8+.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.