Tracks with NO composition

simply amazing.
i think you all solved my problem! i’ll report tomorrow, the the multipart setting… is the solution.
:slight_smile: :slight_smile::slight_smile::slight_smile::slight_smile:

I think this is something everyone is going to need to make their own mind’s up on. With my particular library and my particular tagging habits I find exactly the opposite settings work better and involve less effort.

So what I do is I set file multi-part globally and revert to roon on a case by case (album) basis when something has gone wrong to see if roon can do better. It’s the mirror of what you advise. Over a period of 18 months I have tried both ways and I know what works for me. Having said that I would much prefer it if i could rely on roon defaults but that is not my experience and I have given up on that some time ago.

So I can give the opposite example:

Roon multi-part set globally:

File multi-part set globally

We can both give many counter examples I am sure. At the end of the day it is going to be a judgement call which way works best for each individual library.


OK. I still think it was worth mentioning what impact this setting may have. If there wouldn’t be a properly identified Creation in your library the example wouldn’t look as good as it does. So if you’ve got only a single instance of a work / composition you will loose potentially available rich metadata if set to file, I think.

My conclusion for today: what this all boils down to is insufficient metadata from Roon. Will this ever change without giving users a better tool set within Roon to adjust stuff? I doubt it. Also, I doubt that we’ll get those tools for making the connections Roon and its major metadata provider missed. Now I hope I’ll be proven wrong. :sunglasses:

1 Like

Not at all. I am basing a lot of this on the day to day experience of working on a small travel roon that is about 15% of my home library so I have lot’s of examples where I only have one composition. I can give an example even in the same box.

Roon set globally

File set globally

I hope it works out for you. I know this has been driving you crazy for a while but please take into account it is just a work around. It seems to work because of dependencies between library settings that were never designed with this in mind. To my knowledge this has worked since at least release 1.3 but there are no guarantees it will work in future releases. I think roon are a little skeptical and need convincing why this sort of functionality is useful and should be provided in a more product standard way.

happy too soon :frowning:
it worked for a couple of albums. but then i started looking around in the library, trying to solve missing tracks i could remember… it does not work…

yes. i agree with you:

yes, i can say that roon’s worth for me relies 95% in cross links between performances.
-as i used to tag files… added infos from roon are not so important. especially as they are often wrong
-bios and reviews… i don’t care.

i still would like any kind of comment/help by someone of the @staff @support

You must set all the library options including the prefer file multi-part and WORK tag. Do you have an example of one that doesn’t work and the library options you have set?

1 Like

After playing with this some more: I think to keep the rich metadata it may be necessary to change from Roon to file after identification. Not sure yet…

These are entirely reversible options. Whatever works for you. I’ve never had much success with roon automation so I tend to prefer starting from a “file” default.


i was loiking for one example, and returning to one of the “fails” i have found out… that it worked.
maybe the problem is that i first changed the setting to “prefer file” in the multi-part section and AFTER i have populated the WORK tag (and rescan).
but it seems that the setting change takes affect only if there is a WORK tag… otherwise it reverts to “prefer Roon” (roon is the only program i know when you cannot see the apply setting, you can change the settings, but not see them!!!).

so i’ll look more deeply in other files and see if i can make this cabalistic recipe work.

i have found in the past another situation where the multi-part setting is affecting the composition credits… so i really guess that this is the final solution:

so, @Tony_Casey, i really thank you for your help.

i repeat myself here: i’d like to have a comment from someone of the @support team

Yes, you must set all the library switches and you must also set the WORK tag. I have two roons and I can see that one will work and the other will not with an identical album if i haven’t set all the library switches and the WORK tag. There are a lot of dependencies there and it is easy to forget one.

so… just changed global multi-part setting to “prefer file” … and for classical music to “prefer roon”.

but i don’t have WORK tag for non classical-music. I’ll have to make some tagging…

I use MusicBrainz Picard to auto-populate composer with non-classical music where I have a lot of gaps. I was surprised to see that it auto-populates work at the same time.

The only thing is that with non-classical on MusicBrainz the composer is as likely to end up in the writer tag as the composer tag. Couldn’t really see a pattern. From a display perspective that doesn’t seem to matter as roon treats composer, writer, arranger, orchestrator etc. the same. But I am not so sure that is the case from a process logic perspective.

That’s probably because the information for a lot of works isn’t detailed enough. Writer at musicbrainz is more general than composer or lyricist, see

Hey everyone,

First, I wanted to say that we appreciate your feedback here. The team has reviewed this discussion and discussed ourselves.

We’d like to take a closer look at some of the examples that you’ve found that you’re experiencing issues with so we can more closely identify what you’re experiencing.

I was hoping you’d be able to share an album with us, and also send details (including screenshots) on what you’re experiencing with this album. Ideally, you can zip up the entire folder and send me private message containing a shared dropbox link. If you don’t have Dropbox or need another way to send the media, just let me know.

An example with which I’ve tried to reproduce what Brian described here

The album (let me know if you need a “debug copy” or if it’s available to you):

Track 8 has no composer credits (allmusic doesn’t know about it).

Now adding the composer manually …

… get’s me this:

If I un-ID the album, I see this:

Note: since I’ve played with metadata afterwards I’m not sure if I still have a version in the state the album was when doing the test. Maybe I’ve some backup.

Update: interestingly, when I look at the album properties, I see this:

I’ve applied Tony’s work/part trick … and with this I can switch it on and off.

Hi @dylan
if i can summarize the overall discussion, there are 2 scenarios:

scenario 1: import settings with “prefer roon” for multi-part. then even if you tag files with a composer (and/or a composition=WORK) tag the tracks remain “orphan” with no composition associated. composers are shown under the tracks (if settings ask to), but no more than that: added composers do not exist in the library and the links are not active. this happens not every time, but is quite likely if allmusic has only some tracks without composition.

scenario 2: import settings with “prefer file” for multi-part. then if (and only if) you add both a COMPOSER tag and a WORK tag… the tracks are associated to a composition (=WORK) and the composer becomes real in the library and the link near the tracks is active.

this second behavior is, in my (i think our) opinion, what should be considered as “normal”, whatever settings one chooses. the existence of a composition associated to EVERY track is, for some of us, something which is the real “magic” of roon: something that allows to explore our own library looking for interconnections between albums and artists.

at this point, we can say that the problem is “solved”, as the workaround in scenario 2 seems to work. at the moment, i’m going through a massive tagging task to add the WORK tag to all my files (except classical music, that already has it).
clearly, it’s a workaround: as pointed out by @Tony_Casey, changes in roon code could spoil it, so it’s important for me (us) it does not happen.

besides, it’s not a real solution: in the beginning of my roon experience, i had “prefer file” in the multi-part settings. but that created some peculiar errors in some of my classical music library: parts of composition seen as single compositions or (even worse!) as separate discs of a multidisc set. that’s why i reverted to “prefer roon”

now, the intersection between “classical” and “album with problems if file-preferred” and “album with problems if roon-preferred” could be… null or… just a few.

anyway… hope this helps.

1 Like

Unfortunately not, as the fix cannot be applied to Tidal albums; there is no way to add a WORK tag.

@dylan I have referenced an example above, but here it is explicitly…

As I mentioned near the start of this thread, the problem has been known about for some 18 months. I had assumed that Roon were already working on a fix.


Hi @dylan

I think @Niccolo_Terzi has summarized very well what we think should be default composition behavior. I myself have noticed a groundswell emerge over the last 18 months or so that started with the handful with large classical libraries. Now those with smaller classical and non-classical libraries are also realizing the benefits. I think the reason is that roon is quite a paradigm shift and it takes a while to “get” the possibilities. By trial and error we have come up with a workaround but it would benefit all to find a way of productizing this behavior in some way.

I have to be somewhere today but I will commit to getting you some representative media by PM, probably tomorrow (Sunday) afternoon.

yes, you are right. i’m not a tidal user. but i remember you are, and already said this :slight_smile: