Tracks without ability to maintain composition

Here’s another perfect example of the misbehavior in roon. All tracks of the album are linked properly to the available compositions while the title “Rolling Stone” does not allow for such.

If not found in the internal link-systems, at least the manual composition editing should be allowed and used for linking.

Reading the original it looks like your older, unidentified copies are not seen as “versions”

Have a look on MusicBrainz you’ll see some albums , particularly very popular ones have literally 10’s of releases, different countries , remasters etc . They all measure up on analysis as “different” hence why Roon doesn’t recognize them.

Doesn’t help I know but that may well be the cause.

Also if you have 2 versions, CD & Hi Rez for eg they are seen as the same album hence you have only ONE “Achilles Last Stand” just in 2 formats.

If I look at LZII, I have multiple copies of Whole Lotta Love.

Mike

Hi Mike,

in this particular case, I cannot even alter the composition to merge it with others, etc. To me it looks like that roon blocks the manual override for some tracks, while allowing for others. If the album is unidentified (with all the losses on additional information), I can get every composition to be recognized as performances (versions). In the case of Led Zeppelin, the only album that did not work properly was the Presence, all others are matching up well (at least in my case).

Ralf.

P.S.: I am really willing to take the effort an enter good amount of information to keep my library in proper shape. However, this really annoys me.

Hi @Ralf_Karpa,

For the example above, can you share a screenshot of the entire album in Roon? Is this album identified?

Would you mind sharing this album with us? Ideally, you can zip up the entire folder and send me private message containing a shared dropbox link. If you don’t have Dropbox or need another way to send the media, just let me know.

Hi Dylan,

message sent.

Please let me know if there’s anything else I can do to get this problem solved (not only for that one album).

Ralf.

Sorry, didn’t read the above comment in your post correctly.

If an album is unidentified, you will never encounter this problem. In that case, once a composer is added to a track, the composition editor is open and it is seen as a valid composition which will also link properly.

Any news on this topic?

Hey @Ralf_Karpa – this issue is with our QA team, and once this gets to the top of their queue they’ll look the media you send and we’ll have some feedback for you.

Sorry for the delay!

I do have another - very nasty - example. For Creedence Clearwater Revival’s Cosmo’s Factory I have all tracks linked to compositions which are composed by John Fogerty. However, the 2 non Fogerty songs cannot be linked to the appropriate composition. These are:

  • My Baby Left Me by Arthur Crudup
  • I Heard It Through the Grapevine by Barrett Strong & Norman Whitfield

If I add the composer, it still won’t allow me to get to the compositions.

Regarding my 2 posts (Humble Pie and CCR), I‘ve seen this pattern quite often. When an album has one or two composers who are not members of the band, the composition cannot be related/edited.

Any news on this topic?

I’ve seen roon team asking again for another set of data in this thread which is basically exactly the same problem but also there’s no further communication.

To me this looks like a generic problem with the software - as said - not dealing with the composers properly in the application. This does not make any sense to me.

Adding my two penn’orth to @Ralf_Karpa’s plea.
This has been a problem for over a year, and at various points, @joel, @Ivan, and @dylan have all got involved.
I like to have correct composer links for as many tracks as possible on my albums, but this deficiency in Roon prevents that.

The only explanation I received from Roon (11 months ago) stated
Our theory is that it was caused by one of metadata services giving an information which Roon didn’t interpreted 100% correctly. So, now we have an opened ticket for the issue, and I hope our developer team will fix it

Can Roon say whether a solution is in sight please?

Brian

I opened this topic last year and the feedback above is also 21 days old. Can you please share an update? I feel a bit ignored on this topic (although others seem to have similar issues as can be seen above) and I do not think that customers should be ignored.

Do you have any update on this topic?

Is anyone working on this issue?

Hi @Ralf_Karpa.

Sorry for the delay responding to you here – this was with me, and I can assure you we have not forgotten this topic. Your issue remains open in our internal tracker, and it’s in a queue to be looked at. But please note that investigating and resolving this type of issue requires a lot of resources from our team – from Support, from our Product team, from our developers, and from QA. All of those groups are currently working hard on our next release, which is not focused on this area, so it hasn’t been possible for me to respond yet.

What you probably regard as a straightforward bug or product deficiency – which I understand is frustrating – is actually something which requires a lot of thought and design to resolve in a way which will not restrict what we can do with the product in the future. The way our automated metadata interacts with edits is complex, and it’s an area we’ve actively been discussing – our real (and preferred) goal is to improve our automated metadata to the point where edits generally aren’t needed. For the majority of Roon customers, spending our team’s time improving automated metadata is going to deliver significantly more value than spending the same time building and testing new editing features that will be used by a tiny minority of users. These approaches aren’t mutually exclusive, but the point is that we’re far more interested in getting the metadata complete and correct in the first place so that edits aren’t needed.

If and when we have some news to report, it will be posted publicly at that time. But I can’t guarantee exactly when that’s going to happen – at the very earliest, this investigation will start a week or two after our next release ships, when things start to settle down. And that’s when the investigation begins – if this issue ends up requiring new features or large-scale changes to the architecture of the product, it could be a while before we make a decision on how to move forward. And unfortunately, problems like this often do not have quick incremental “bug fix” style solutions.

Anyway, once we are actively looking over this we will let you know if we need more information. I know these kinds of vague “sometime in the future” responses aren’t what you’re looking for, but this is the nature of software development – every day, we make difficult decisions about what everyone is going to work on, and what gets pushed to next week, next month, or next year.

We’ll be as transparent as we can be as these issues get to the front of the queue and decisions are made. For the moment, I can assure you that this issue is not being ignored, but please note also that “pinging” this thread isn’t going to speed things up.

And as always, we appreciate the feedback here.

4 Likes

Thank you for your considered reply Mike. I applaud your resolve to find a solution where edits aren’t needed, although considering the current state of metadata I think you have quite a task ahead of you.

In the meantime, from the user’s point of view, there is already a track editor which purports to add composers and form compositions, but it doesn’t always work, and that looks like a bug rather than a product deficiency. Now it’s probable that there is a good reason why solving this is difficult, and if so, so be it. Perhaps the effort really is better spent on the long term goal. I’d just like to plead that you don’t let the perfect be the enemy of the good.

Don’t take this as criticism. I do appreciate the hard work and forward thinking.

Brian

2 Likes

So, I have been quiet over a year now and nothing has been posted here. May I politely ask whether there are any news on this problem? There are still a lot of tracks in my library where I cannot edit the composition.

1 Like

2 years since I opened this topic. Adding the 11 months from BrianW’s post, we’re at around three years now on this topic. roon is telling me that it is with the QA team, but, sorry, is there only one person working on part time?

I have been in IT development for more than 30 years and I can assure you that the companies I was working for would never have accepted such behavior. If it is a bug, ok, please fix it. If the developers cannot find it, state it. If it is a deficiency with roon, please state it. But, please do not tell me that no one is being ignored if you are behaving like this.

Sorry for the harsh words, but I feel a being fooled here…

1 Like

I have the same problem with classical music. Identifying the album the track loses the composition feature. If I unidentify the album i have it.

Reading the threads i have looked in musicbrainz database. There it is described perfectly

It is not understandable why roon isn’t able to identify this album. Trying to use file metadata for the track doesn’t do anything.

So the question remains open and I wonder why roon doesn’t answer