Transport: Failed To Load Media Errors with Tidal

Roon works fine when playing my own stored files, but I cannot get Tidal to play anymore. The problem seems to have started when rearranging my router, switch and Ethernet cables. Tidal albums and playlists show up fine in Roon, but when play is pressed I get no sound and “Transport: Failed to load” errors plus “Too many failures”. My endpoint is an ultraRendu connected to my QX-5 DAC.

I think I’ve tried everything. I’ve rebooted every device, logged in and out of Tidal, cleared cache etc. I’ve attached a screenshot of some of the Roon Server Diagnostic. Any ideas?

Thanks for sharing your report with us, @Ultrarunner.

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this only happen when playing to this particular endpoint? If you connect the QX-5 DAC to the Core machine directly via USB and just play to it, do you experience the same behavior?


Ok, here is some more info on my setup:

My Roon Core runs on a Linux device made by Small Green Computer. It contains about 1,200 albums on 2TB SSD storage… This SGC Linux server is connected to a Ubiquiti AMPLIFI router. The router connects to a Cisco unmanaged switch in the listening room. The switch connects to an ultraRendu, which is connected by USB to the DAC. Every device has been updated to the latest software and firmware available.

Tidal has run fine in Roon for the last year, and fine playing directly to the DAC. The only significant change is the router change a few weeks ago. Even then, Tidal still worked fine until a week ago. Roon itself has always played my own files with no problems. So I assume it is some sort of network issue relating to the AMPLIFI router. Hopefully the log I attached will provide some help.

Thanks for the details, @Ultrarunner!

By this you mean that it is currently able to play fine directly to the DAC via USB, correct?

In that case, yes, it definitely sounds like there may be some networking issue at play here.

First, I’d like to propose trying to connect the ultraRendu directly to the router, bypassing the switch. If you do this is there any change in behavior?

I’d also like to recommend trying Google DNS. In the past we have seen other users improve their TIDAL performance by using this.


Really, that says it all.

My problems started when an Access Point, that I was using as an extender and had forgotten about, became unplugged.

Probably a network problem.

Ok, it took some doing, given the longer length Ethernet cable I needed, but I bypassed the Cisco switch and went direct to the ultraRendu. I also bypassed both the switch plus the ultraRendu, and went direct from router to DAC by Ethernet. Both yielded the same results: Roon plays my files with no problem but Tidal will not play.

So the default router settings must be the problem. Before I start messing with IP addresses, which device specially do I need to change? Can you tell from the log?

Thanks for giving that a try, @Ultrarunner!

Can you confirm whether or not the DAC works via a USB connection to the Core machine? If it does work then we know the issue lies between the connection of the Core machine and the networked endpoint. If it doesn’t work, then that tells us the Core machine itself may be having networking difficulties with TIDAL.


The core machine is a version of the SonicTransporter. It attaches to the network by Ethernet only, not USB.

Understood, thanks @Ultrarunner!

This change (using Google DNS) should only need to be done on the Core machine (Sonic Transporter). Try giving Google DNS a try and let me know if there are any changes in TIDAL performance.


I ran the log by Andrew Gillis of SGC. He said NameResolutionFailure means the router isn’t able to “resolve the address”. He said changing the IP address will not help. Isn’t there someone at Roon that knows about this specific problem? I’m wasting money on a Tidal subscription that is useless and getting nowhere.

Also, why does internet radio stream fine in Roon but not Tidal? Perhaps the difference between the two would explain why Tidal will not play.

Hey @Ultrarunner,

In the past we have seen this NameResolutionFailure error that you’ve seen in the logs be caused by DNS issues on the network, and we’ve seen customers have success in using Google DNS to resolve (an example). It is also worth looking into your router’s current firmware version and being sure that it is up to date.