Transport: Failed to select Roon as the current source [dCS Vivaldi]

Thanks Brian , did a " hard" reset on Vivaldi Upsampler and , for now , all is well . I sent you an email as well so I could copy John Quick at dCS in case they were not aware of the problem .

Just had a similar error message with the dCS Network Bridge.

Just had this error with the Network Bridge. I see from some other threads this issue has shown up in dCS and Bluesound devices.

Same error overhere with my dCS network bridge…:cry:

How do you restore ROON? Power cycle the Bridge. Have sent an email to dCS support to link to this thread and the among others, this one below.

I only see this message for 3 or 4 sec. after this the bridge starts to play and works just fine.

That sounds like good news… mine needed a reboot…let’s keep up the dialogue with dCS.
How does your bridge sound, btw?
Mine is giving us the best digital we’ve had in house.
Cheers

@Wdw and @Kees_van_der_Wal

You are experiencing a known issue with the Network Bridge and rest assured it’s being actively worked by dCS and their software partners. I don’t have a timeline on the fix yet, but it’s on the top of everyone’s list.

The problem is primarily related to repeated sample rate changes (a mixed format playlist) or operations that quickly change the state of the Roon stream (i.e. unpausing in the middle of a track and then quickly skipping back to the beginning). This causes a lockup in the network card that takes the device offline momentarily. In most cases you can wait for the card to reset the Roon endpoint code and everything is fine. You can also power-cycle the bridge from the rear panel and that will also reset the card.

I’ve been working with the bridge longer than anyone outside dCS and have found that setting a resync delay within Roon (in audio device settings) can help significantly so it’s worth trying. I typically set it at 1s - 1.5s (or 1000ms to 1500ms). Give that a shot and see if the bridge is more stable for you.

Thanks. The Bridge is so exceptional that these issues are not too much to worry about. Have a suspicion that dCS will work this forward to some solution.

with my Rossini also the same problem.
This is taken to long for a solution now.
In my sittuation this helped:
Upsample all files to DSD 128 in Roon.
No problems with playback anymore …

I trust the guys at dCS will come up with a solution…:ok_hand: After auditioning several network players, like Aurender, Auralic and Lumin I went for the dCS network bridge because it sounded the best in my situation (to be honest: I think it depends on the kind of DAC you use with it)

I love the sound of the dCS products but waiting now for more than 6 months for the solution.

Hi @support,

I am having the same problem with the DCS Network Bridge. What is the solution? Thank you

This one seems to crop up, despite setting a long delay, even when, say, an album at 192k is ending with another, at 88k is queued up. The new album hangs up. Pressing play fails. I need to completely clear the queue and restart the 88k album.

Yeah, this is a known bug. What’s happening is the network card in the bridge is getting confused and the RoonBridge process that’s running on it is locking up. Eventually the bridge notices this then kills and restarts the process. This usually takes a couple of minutes to complete but if you’re willing to wait it out then the Roon endpoint code on the bridge should reset and you shouldn’t need to completely clear out the queue.

The root cause of this problem has been identified and addressed, but the bridge firmware that includes the final fix isn’t done yet. I don’t know which bridge firmware you’re running, but it’s worth contacting your dealer to see if they can get you a copy of the most recent beta firmware. (Don’t contact me as although I have it you need to work this through Music Lovers). This version addresses most of these issues, but it’s not a complete fix yet.

I keep tabs with my dealer and they’d have informed me of a firmware update. Like many others, I’ll have to sit tight until dCS finally releases the code. It already appears that they will miss their target dates announced on their own web site.

FWIW: I experience the sample rate change glitch with the WASAPI driver…but it is not evident with the dCS ASIO driver…

Running Vivaldi DAC with USB feed from a dedicated/fettled Audiophile Optimized server…

This may be due to some things that AO does in the process of “optimizing” the configuration of the host OS. From the DAC standpoint its communications are essentially the same whether you’re using ASIO or WASAPI. The real difference between the two is what parts of the operating system are involved in the playback chain. This could also be an issue with the driver itself or an interaction between Roon and the changes that AO makes.

Two things to check:

  1. Do you have the latest version of the dCS driver downloaded from the dCS website?
  2. Disable AO and try again. Do you see the same issue?

You don’t mention what version of Windows you’re running, but I have seen some issues with WASAPI on Server 2012 as the WASAPI support there is a bit of a hack. There could also be an issue with one of the recent Windows updates as it relates to the playback chain.

Any particular reason why you’re using WASAPI instead of ASIO? If it’s computer used solely for audio playback then there’s no reason not to use ASIO.

Experienced the issue with Roon glitching on sample rate change through the Vivaldi USB WASAPI driver prior to and after using AO

AO both on Win 10 and in a prior incarnation with Win 2012 R2…Single PC constructs…with Process Lasso also operative on the Win 10 build.

Am fine with using ASIO…just was (intellectually/debugger) curious as to why the WASAPI path was failing…that and a mild touch of OCD :slight_smile:

7 posts were split to a new topic: Playback instability when changing sample rates [dCS Network Bridge]