Transport loses control at bitrate changes


I’m running Roon Version 1.4 (build 310) 64 bit on a dedicated HP PC quad core i5 processors and 16 GB RAM under Windows 10 PRO (1709). My Yamaha AS-810 amp has a built in DAC that’s theoretically high quality (Yamaha Steinberg USB ASIO). I’ve updated it with the latest driver (version 1.9.10, from 3/7/2017).

Unwanted Behavior: Whenever the bitrate changes (up or down) I get a message “Transport: Roon lost control of audio device.” Playback stops until you hit the “Play” button. Which is disruptive and annoying…

Attempt 1: Tried setting a 4 second “Resync Delay” but no change in behavior. Tried tons of other settings, no change in behavior.

Attempt 2: Reviewed the post in Support from another Yamaha AS-810 user, cloned their settings, but saw no change in behavior. Noticed that they were using an older version of the AS-810 driver (1.9.8 vs. 1.9.10 on mine)

The good news is that the new Yamaha driver supports all the different bitrates, it’s a shame that it doesn’t work seamlessly with Roon.

Any suggestions outside of buying a Roon approved DAC?

Thank you!

Sorry, first time poster … should have added @support in the prior message…

Hi @Mark_Howard ---- Thank you for the report and sharing your feedback with us. The insight is always appreciated and sorry to hear of the troubles.

Moving forward, to help aide in our understanding of this behavior you are experiencing, may I very kindly ask you for the following:

  1. Please confirm how the AS-810 is communicating with Roon.

  2. Do you have any other audio zones in your setup? If you do indeed, do they exhibit the same behavior?

  3. Please provide the following screenshots…

    • Your signal path leaving Roon when you know the issue is going to occur.
    • The “device setup” window highlighting all the settings being used with the AS-810 zone.


@Mark_Howard You could try setting the DSP upsampling to up/down sample everything to a fixed bitrate (say 24/192) and see if that helps.


FWIW I have a NuPrime uDSD that does the same thing…falls apart when there’s a sample rate change. It’s a hardware issue, not a Roon issue.