Transport: Roon lost control of audio device with SONOS


I am getting “Roon lost control…” when playing to one of my Sonos devices. All my sonos devices are ethernet connected. I could not control the sonos device with Sonos remote when this happened and had to power it on/off to get it back online again.

Using ipad as remote for Roon and all my FLACs are stored on my QNAP NAS. I am running rock on recommended I7 NUC. Attaching logfiles for easier troubleshooting.


Operating System
Version 1.0 (build 148) stable
Running 7 minutes, 53 seconds.

Roon Server Software
Version 1.3 (build 262) stable
Running 7 minutes, 46 seconds.

Roon Database & Settings
93% of 114 GB available.

1 Like

Hi, @Patrik_Falkm thanks for the provided information here, we’ll contact you as soon as we get some cosistent information about your issue.


)Hi @Patrik_Falk ---- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, I have downloaded the provided logs and have added them to our queue for evaluation. I would also like to gather some additional information from you, for my report. Please see below.

  • Please provide the details of your network configuration/topology, being sure to provide insight into any networking hardware you are implementing. I want to have a clear understanding of what the “chain of communication” looks like in your setup and how information is making it from RoonServer to the mentioned Sonos endpoints.

  • Please verify, which Sonos device (model) that you are experiencing this behavior with.

  • During your troubleshooting, have you tried…

  • Rebooting the NUC i7 hosting ROCK, the Sonos endpoints, and any additional networking gear (i.e router(s), switches, etc)?

  • Disabling all other Sonos endpoints and seeing how just the one behaves running by itself?

  • You mentioned that all your Sonos devices are ethernet connected. My assumption is that these devices are not connected directly to the router you are implementing ( please, due correct me if I am wrong :innocent:). Have you tried moving the single Sonos device to a direct ethernet connection to your router?


Please see the requested information below.

One single lan with adress space.

One UniFi Switch 24 POE-250W with the NUC i7 running rock directly attached. Also QNAP NAS directly attached to the same switch (in the basement to get rid of noise).

To this unifi switch is a Netgear ProSafe GS108 switch cascaded (in the living room) and to the netgear is the Sonos Connect:Amp that experience this problem attached.

CONNECT:AMP: Vardagsrum
Serienummer: 00-0E-58-33-19-78:C
Version: 7.4 (build 37244160)

During the troubleshooting i began by restarting ROCK to see if it would fix the problem. It did not.
Tried to access the Sonos device through it’s own app/interface and it did not react to any commands.
Rebooted Sonos by pulling power and restarting. After that it was accessable again both through roon and the Sonos App.

I will try to remove the Netgear switch and connect Sonos directly to the Unifi switch and see if I can get the problem again.

Hi @Patrik_Falk ----- Thank you for touching base with me and providing the requested information :thumbsup:

Moving forward, I wanted to touch base with you to see what the results were of the proposed test.

“I will try to remove the Netgear switch and connect Sonos directly to the Unifi switch and see if I can get the problem again.”

Looking forward to your feedback!


Yes I am able to recreate the problem with the Sonos connected directly to the same switch as the ROCK server. Please see attached logfile for another case of the same problem.

Thanks for the follow up @Patrik_Falk, very appreciated! Confirming that both sets of logs have been received and are in our queue to be evaluated by a member of our tech staff.

Once my report has been updated and passed back, I will be sure to follow up with the team’s thoughts/findings. Your patience is greatly appreciated!


I can continue to supply you with logs since it’s happening on a quite regular basis.

Thanks @Patrik_Falk, we should have what we need :wink: If the team requires more, I will be sure to let you know.


2 posts were split to a new topic: Sonos - Lost control of audio device

A post was split to a new topic: “Sonos: Play5” endpoint issues - “transport lost control of audio device” error

3 posts were split to a new topic: Sonos - “Lost control of audio devices” (“Play:1”) (“Playbar”)

@support Is there any resolution to this issue? After using Roon faultlessly with my SONOS system for some months, suddenly I get this “lost control” issue all the time to the point where it’s making the application unusable.

1 Like

@Peter_Murthwaite — Just to bring you up to speed as to where we are with this behavior.

We actually scheduled some field testing at Roon customer’s home who has been having similar Sonos issues. Being as we have not been able to reproduce this issue in our QA labs reliable, this was most logical move for our team.

The good news is that we were able to reproduce some issues in his environment, and we have gathered a lot of diagnostics for our QA team to process and turn into bug reports for our developers. We’re not out of the woods quite yet, but this is an important first step towards resolving these issues.

We know that Sonos continues to be stable for some users, but we also know these problems are somewhat common, and we’re working to make them a thing of the past. This testing got pushed off for a few weeks in the run-up to 1.5 but its on the front burner now, and we’re hoping to make some real progress in the next few weeks.

We appreciate your patience!

1 Like

Hey @Patrik_Falk & @Peter_Murthwaite,

We recently made some improvements to our Sonos integration in Build 334 and we are hoping things will be more stable for you now. Please let us know how things are with Build 334 on your Core. If you continue to see any instability please let us know and we will be happy to take a look!

Thanks for your patience! It’s genuinely been appreciated.


1 Like

Thanks for the update @dylan. I have tried to force a “lost control” error during the last day with heavy changes between tracks (an easy way to induce the error in earlier builds) but have so far not been able. Will continue to see if I am able but so far it looks very stable at my site.

1 Like

A post was split to a new topic: Consistently losing connection with Sonos speakers