Transport: Roon lost control of the audio device because the input was switched

Hi guys,
I’m having a problem with the above message. I use Roon with my Devialet amplifiers, using it to access high res. files on a NAS drive, to stream from Tidal and to listen to radio stations. Everything is connected via Ethernet. Recently, I changed to a beta version of the Devialet operating system and started getting the above message. No problem I thought, I’ll just revert to the previous firmware version, but no, the problem persists. I run Roon Core on an iMac 5k with 32GB of ram, using an iPad Pro as a remote controller. I have tried restarting all of the hardware and deleting and reinstalling the iPad app. Everything short of deleting Roon from my Mac and starting from scratch, which I am unwilling to do unless absolutely necessary, for obvious reasons.
Can anybody please give me any advice as to the cause and remedy of my problem?

Apologies, I have just found another thread about this issue, but couldn’t find a way to delete and re-post in the appropriate place. Can A moderator move this post, please?

Cheers, and I hope everyone has a merry Christmas and a happy, peaceful and prosperous new year.


Done. Let me know if you want Support to look in also.

Merry Christmas !


Thanks Andy,

For anyone else with this problem, here’s how I fixed it. My Hi-Fi is Fed from a dedicated spur from the fuse board. I switched the feed off and back on, and the problem had disappeared.
Pulling out the power cord and reinserting would have the same effect.

Thanks Alex for the trick on how to fix this problem. I encountered the very same problem after upgrading my Devialet Expert Pro 1000 with the Infinity Core +DOS +new firmware. I thought I could only solve the problem by installing the Devialet Air 3.0.4 driver, despite Roon can still see my Devialet via Devialet-ETH. Alex’s trick solve the issue and I do not need to install Air 3.0.4 driver now.

However, there are still some issues using Roon 1.4 with Infinity Core - when playing DSF (DSD) file, only the main amp plays, while the companion (slave) amp shuts down. The same situation happens when playing 176.4 files.

To solve the above issue, I have to use Roon DSP Engine to convert the DSF file into PCM 24/96 in order to play it flawlessly. This was not the case before.

Thanks for the feedback and the DSD workaround. Glad my tip worked for you and saved a lot of messing around, when all we want to do is listen to some music!
Some of the guys on the Devialet forum have encountered the DSD problem, so I’ll post on there if you haven’t already done so. Are you a member of Devialet Chat? If not, please join, it’s very friendly on there and a mine of information, covering all sorts of issues. We need clever people like you! (Not that there aren’t a lot of clever people on there already).

Thanks for the invitation. Never been to Devialet Chat before, but definitely shall pay a visit. Wonder which post at Devialet Chat forum refers to the DSD problem?

[Update] I have just found the post you mentioned, but as a new joiner, I do not have the right to reply yet. I am grateful if you may reply on behalf of me.

I think you’ll find that anyone, whether they be a newbie or an oldie has the right to reply to any post.