Transport stops or errors when adding or deleting sonos devices from group

I am having issues with roon and its management of sonos devices. The main issues are either playback stopping and needing “play” to be pushed to restart and also the “Transport: Roon lost control of the audio device” message. These issues occur mostly when adding or removing sonos devices from the group, but they have also occurred when making adjustments to sonos volume levels.

I mainly play uncompressed 44/16 flacs from the NAS, or stream Tidal. Ive done a fair amount of testing by adding and deleting sonos devices in different order and quantities. What Ive found is that ROon will stop playing nearly every time 2 or more sonos devices are simultaneously added to the sonos device that is playing, or every time that one sonos device is added to the playing sonos device at the same time as another is removed. Adding or deleting sonos devices separately rarely causes an issue. Ive tried choosing each sonos device as the main output and then adding and deleting other sonos devices from it, and no device seems any more or less likely to cause the issues.

RoonServer is running on a nuc 6i5syh with 16GB RAM, running windows 10, with roon 1.3 Build 218 stable 64bit (note Ive not yet tried with the new build 223). Ive tried both server and full installation on the nuc with the same issues. Music is streamed from a Synology ds415+ NAS.

I have 6 sonos devices on the network of various ages. 4 are connect amps, 1 is a connect and one is a play 1. All are up to date with the sonos firmware. All are on ethernet cables and work perfectly with the sonos app itself, and have done so for many years.

I have an asus dsl- ac68u router which is the gateway and dhcp server, and also adsl+ modem. Ive allocated manual IPs in the router to all sonos devices. From the router I have 4 separate directly connected d-link gigabit switches on 15 metre cat 5 cables. Switch 1 has 3 sonos devices on it as well as the nuc, Switch 2 has 2 sonos devices on it, switch 3 has 1 sonos device and switch 4 has my synology DS415+ which holds the music library.

In trouble shooting this issue I ran a sonos report on the network using the http interface and could see that the sonos mesh was not ideal on a number of the units, so I have disabled wifi on all of them using the “wifictrl?wifi=off” command and run it this way for a number of days but the issues remain. From what I have read this is the preferred way to use sonos when the units are all cabled. I have pinged each unit and there are no issues, and as stated they all respond properly to the sonos app.

As a test to see if the network topology (ie excessive use of switches) could be an issue I also tried connecting the Roon NUC directly to the same switch as 3 of the sonos zones and then (streaming Tidal) tried with just these 3 zones, the same issues occurred.

@support will hopefully get some attention to this…not my rice bowl :expressionless:

I seem to recall someone else having a multiple Sonos Issue or maybe was RPi when grouping more than 2 devices paling simultaneously - perhaps something going on here that I can try as I have a few non RAAT endpoints I can group around the place.

Hi @Adam_Duke ---- Thank you for the report and my apologies for the wait here.

I would like to grab some logs from you as per the request of my tech staff and will be contacting you shortly via PM with instructions.