Trial Roon running very (very) slowly

I have Roon installed on my desktop PC (8-core Xeon with high definition audio), linked to Tidal and a QNAP server where my music is stored. All on the same ethernet hub.

My issue is that it is slow, to the point of being unusable, all the time.

Clicking on “My library” takes about 20 to 30 seconds to respond in any way, the same with most other clicks. It does play, but you never know whether you’ve clicked the right thing until half a minute later.
Scrolling with a mouse wheel down the list takes 3-4 seconds to register.

This may be unrelated, but unplugging headphones and re-connecting them (to my PC) has caused Roon to not recognise them as an audio output. I can still listen with other Windows apps though.

I have a Cambridge Audio CXN V2 that I’m keen to use, but if I can’t get it to work on my PC I’m not going to try with that.

I’m on the first day of my trial, but at the moment I may not make it to my second day without cancelling.

Is it me?

Nope, but it might be your NAS, either because it has to wake up, or because Roon is still building its library, so scanning stuff and reading through every song on there to make sure integrity is good and to make the volume graphs and all that stuff, and that’s obviously WAY slower over the network than it is with a local drive… Roon calls this “analysing”, and if that’s what’s going on, you’ve got a turning ball thing in the top right you can click on if you’re curious how far along you are.

If analysis is ongoing, and you’d like to know “now” if Roon is zippy enough for you, remove your NAS as a source from your library, and stick to Tidal. If you’re OK with waiting a little bit, let the process happen, 24/7, over the next couple of days (depending on the size of your library).

1 Like

Go to settings > Library is it showing any activity ?

If it shows 1000 out of 2000 or anything like the core is still analysing as @Xekomi mentioned. This will slow things down badly.

If so set the number of cores to Throttled then when you go to bed set it up to Max until that message goes away

The CXN , have installed the CA Windows USB 2 driver ? That enables 24/192 as opposed to 24/96

Then plug the USB In to the core PC Roon should see it. Is the CXN on the same network as the core ? If so Roon should see it in Settings Audio Network devices. You will need to click Enable in both cases

Just curious here if having your library on a NAS really slows everything down that badly?
I know on both the Dell laptop and my present NUC being used as cores I saw no slowdown.
I had analysis set to fast 2 cores but the big difference was music was in an attached 4tb USB HDD.

Even while it was deep in analysis response to all functions was what I would deem to be normal.