Tried everything from the help page regarding Roon Arc as a lifetime member

Roon Core Machine

<Synology DS920+>

Dear support team,

I have read the artical carefully and tried all the approaches, but Roon Arc is still not working.

I have two routers: 1st, OpenWrt, 2nd, H3C GR1108-P.

I have set the second one with mamual port forwarding and even switched DMZ on (Appologize it is in Chinese):

I have set the first router OpenWrt with port forwarding

The diagnosis is below:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 156.ggg.hhh.iii:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“156.ggg.hhh.iii”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Is that because that I have to have a Stastic IP from the ISP?

Networking Gear & Setup Details

<1st, OpenWrt, 2nd, H3C GR1108-P>

  1. Who is your internet service provider? China Telecom

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Is your network on 192.168.2.x or 192.168.20.x

Your port forwarding rule is on

Do you have VLANs setup or something as it looks like a multi NAT issue

Yes it is multiple NAT.

I have two routers which are necessary. First it is OpenWrt with the ip address
Second is a AC
Roon Core is

I thought it is possible to set two port forwarding so that I can get through multiple NAT issue, worst case I can active DMZ since it is only about movie and music in my NAS

Are you using this as a kind of managed switch as it has multiple LAN ports

Don’t activate DMZ!!!

1 Like

Normally I’d agree, but they could on the 2nd router as it’ll be behind the 1st routers firewall.

However, I believe the 2nd router is being used more as a managed switch. But as it’s a router it’s causing multi NAT issues.

If OP comes back to confirm my theory I’d recommend a dumb switch of a carefully setup managed switch.

Hi @Yaohong_Shi,

Is your Roon Core attached to the H3C GR1108-P Router? If so, i would suggest that you set the OpenWrt router in bridge mode and remove the port forwarding there.

If your ISP hasn’t implemented CG-NAT, this will solve your MultipleNat issue and then Roon Arc should work.

Kind regards,


Thanks, I will try this solution.

Nevertheless, OpenWrt play a critical role of shadow sockets (as you might know, I am in mainland China). I have to keep it as a router for that purpose:)

If I can understand correctly, Roon Arc only work with one router, am I correct?


Forgive my Eng, I cannot comprehend the meaning of ‘a dumb switch of a carefully setup managed switch’.

As far as i know, when there are multiple routers, we have a NAT issue. This is not allowed for Roon Arc.

If the OpenWrt has to be in router mode, than you could also try to do a port forwarding from OpenWrt to the ip address of the H3C router for the same port number and in the H3C a port forwarding to your roon core for the same port number.


This is really helpful Maaten, can u be specific how should I do that?

From WAN to H3C LAN through port 55002, sorry it is in Chinese.

Add images

Then in H3C, add one port forwarding to (port from 55000 to 55002)

But still, it is not working…


In the Roon App under Settings → Roon Arc what is the port number and IP address?

And what is the ip address of the HC3 Router?


Roon Core is Port: 55002

Diagnosis is:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 156.ggg.hhh.iii:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“156.ggg.hhh.iii”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

H3C WAN ip:

I think my config is right, but somehow 2 port forwarding is not working. Sorry to bother u guys

I have had this issue in the past when I had multiple NAT devices and solved it as follows:

  1. Set port forwarding for your Roon ARC port on the First router (the one connected to the modem) to forward to the wan side IP address of the 2nd router (be sure your 2nd router always gets the same IP address from the 1st router).

  2. Set the port forwarding in the 2nd router to be your core as you have it.

Then when ARC connects from the outside the first router knows to send it to the second router. The second router knows to send it to the core.

I no longer do it this way but have in the past for other applications (such as iPeng or JRemote) and it worked.

Really appreciate it Larry.

Can u have a look at my previous post: I have added port forwarding to which is my second router IP address. And I have configured the second router H3C port forwarding to which is the Roon Core.

Still, it is not working. Is that because of the capability of H3C?

Or is it because I don’t have a drastic WAN IP?

Is there another way to get it done? I am really desperate now.

So based on the diagnostics that you provided, it’s obvious that Roon sees multiple NAT situation and doesn’t like it. It’s probably because Roon core is reporting to Roon’s servers what its outside IP address is and of course that would be the IP address of your second router HC3.

So of course, when an Internet call comes in to that HC3 IP address it doesn’t exist in your external IP. Is your Roon core computer a dedicated one only for core? I suppose if it was, you could hook it to your primary router. If it’s used for other things then that, defeats the purpose of your multiple routers as you indicated above.

I suppose the other thing to try would be to set the IP WAN address of your HC3 to be the same as the external IP address of your primary router but I’m sure that would cause a multitude of other problems. I’m not technical in that manner so don’t know specifically. I haven’t really looked back at the other threads that talked about multiple routers to see how people solved them. The only other thing I could think about was to set your core device in the HC3 so that it passed through everything from the Internet without doing any address translation on the second router, but again that might defeat the security protocols you have in place.

The first thing I would try now, in case you haven’t figured it out already:
Call your ISP and find out if your ISP is using CG-NAT, because Carrier-grade NAT prevents ISP customers from using port forwarding.
Carrier-grade NAT - Wikipedia.

Thanks for THE help of all friends.

I will try the solutions u guys suggested, hopefully Roon can have an upgrade so that remote access can be as easy as softwares like ToDesk, Huashengke:)

1 Like

Please have a look

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.