Trouble accessing files on remote storage after MacOS Catalina fix

Core Machine (Operating system/System info/Roon build number)

Core is on a Mac Mini which was not upgraded to Catalina until after the Roon fix was announced. Showing Roon Build 475, Catalina v 10.15.1

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core is running on Mac Mini connected to audio system, networked via Eero wi-fi system. Has been extremely stable with no issues since initial Roon installation about one year ago. Music files are on a Synology NAS which is hardwired to Eero router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various devices - Peachtree USB, Sonos devices, all working fine from Tidal streaming but no access to files on NAS.

Description Of Issue

I held off on upgrading to Catalina on the mac mini running the Roon core until after the announcement of the build 475 fix. After advising the fix was available, I upgraded to Catalina earlier this week.

Roon shows that it lost access to my files. Upon clicking to edit the connection, I was prompted by MacOS to allow access which I accepted. However, got a file access error.

I removed the previous file location and attempted to add a new folder. The Roon menu shows the location of the NAS, and it is accessible via Finder. However, any attempt to connect to the folder results in an error.

This may be a simple configuration problem, but I’m not an expert user and am stumped as to what to try next.

Hi @Scott_Purdy,

Thanks for reaching out to us here. I see that you are trying to connect to the NAS via hostname (as in \\JSPNAS, can you please confirm if connecting via IP Address has the same issue?

Also, are you still able to connect as expected to the NAS share outside of Roon? You can use Mac’s Connect to Server feature to give this a try.

Thanks for the prompt reply.

I’m not sure I know the correct format for connecting via IP address when trying to add the network share from within Roon (see screenshot)

I tried to enter using the following conventions
(I used my actual address rather than the X’s)

All of these returned an Invalid Network Path error - which is different than the error I get when I try to connect to \JSPNAS\MUSIC, when it brings up the Roon icon and thinks for a bit, then returns an Unexpected Error message.

I am able to connect normally outside of Roon. The Mac mounts this server volume upon startup, since I’ve previously used the Connect to Server feature to mount it. I just tried to do it manually again and it works, using the same IP address I’m trying from within Roon. Don’t know if it matters- but the NAS requires a Username and Password - which I also entered from within Roon on the unsuccessful attempts.

Also, I checked and can confirm that Roon has access to remote folders.

Hi @Scott_Purdy,

Thank you for running those tests.

Can you please try specifying cifs://XXX.XXX.X.XXX where the X’s are the actual IP address and using the username/pass for the share? Does connecting via that method work?

Also, can you check to see which SMB version you’re using in the Synology config? Is it SMBv1?

Thanks Noris.

Using the CIFS:// convention, the address was valid and Roon responded that it was adding the network share. After about 30 seconds, an Unexpected Error was reported. This looks like the same error as when using the share name.

I don’t know much about the Synology, but found this SMB option on the Synology control panel - which seems to indicate it supports SMBv1 and SMBv2.

Hi @Scott_Purdy,

I would try setting the minimum SMB protocol to SMB 2 and maximum SMB protocol to SMB 3 and see if that helps.

I was able to make that change on the Synology, but it did not fix the problem. When trying to connect via the share that is shown already, I get an “Error Loading Folder - Not Available” error. Trying to add the share results in the same Unexpected Error message that I have been getting.

Hi @Scott_Purdy,

Thanks for giving those settings a try. I would next like to take a look at diagnostics to see if these reveal further clues. Can you please try adding the share again with the CIFS notation and let me know the exact local time + date in your country when you try to add this? I will then enable a special diagnostics mode for your account and I’ll take a look for any additional info contained at that timestamp.

OK, I just gave it a try, same results. I attempted to add a network share using the CIFS convention first at 5:21 PM CST. That returned an Unexpected error message. Following that, I also tried to add a folder using the share name that was already shown on the volumes list - \JSPNAS\music. That returned an Error Loading Folder - Not Available message.


Full time plus date I tried was:

5:21 PM CST on November 18 from USA.

Hi @Scott_Purdy,

Thank you for letting me know those timestamps. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Hi @Scott_Purdy,

I can confirm diagnostics have been received and it looks like you are getting a Error connecting to network share: 68 type error, which indicates that the operation to mount the share is timing out. I have a few follow-up suggestions:

  1. Can you please check to make sure that the SMB service is still enabled in your Synology settings? This similar thread outlines what these settings should look like:
  1. I have done a bit of additional research and it appears that NetBIOS has disabled in Catalina. If your Synology is using the older SMB connection method, you might need to either update the Synology firmware or edit the nsmb.conf file to allow access via this connection method. This article provides an outline of the steps, but I would verify the first point before taking a look at this:

Checking the settings on the first thread, I found only the Enable SMB2 Lease option that was not enabled, but adding it did not fix the problem.

In reading through the other comments in that thread, I tried various combinations of entering the file path adding my /music directory, and was able to get connected! This convention was the one that worked:


Folder scan is complete and my library has been restored without any changes that I’ve noticed so far. Will continue to explore and test it out, and will respond if there are any more problems.

Thanks much for the help!

1 Like

HI @Scott_Purdy,

Glad to hear that the new SMB convention worked out! Hope you have a great day and a continued enjoyable Roon experience :headphones:!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.