Trouble after Mac Mini OS upgrade

Roon Core Machine

MacMini (late 2014) Monterrey OS 12.5.1.

Networking Gear & Setup Details

Connected Audio Devices

USB to PS Audio Stellar Preamp

Number of Tracks in Library

Description of Issue

Everything was working find under previous version of Monterrey. But now I cannot get it to output anything to the USB & Preamp. I’ve forgotten how to setup devices in Roon to do this, and so far, anything I’ve tried hasn’t worked. Help!!

Roon setup audio device shows 3 options: System Output, HDMI (I use this for Mac display monitor on a TV), and a CoreAudio which I’ve messed with. If I enable system output, it plays on the Mini’s speakers. If I try to set up CoreAudio and pick “PS Audio Direct Stream” device, it still plays on Mini’s speakers.

I’ve tried enabling, disabling, restarting Roon multiple times. I had to type in the PS Audio name. When I selected it, it didn’t put the name in right.

I’m pretty lost on what to do. It was all working fine until I did the Mac OS update. My setup if pretty simple, just the Mac Mini with Roon connected to PreAmp via USB. I’d hate to have to reinstall Roon and redo the playlists again.

Appreciate any help. Obviously I’m very frustrated. I’ve been a long time Roon user.

David Salguero

David, have you tried powering off and disconnecting everything, starting with rebooting your router, then reboot you Mac mini, plug into the USB port the PS Audio Stellar Preamp, turn on the Stellar, then restart Roon? The order may be important as everything settles with the network and drivers. You select devices in the Roon Core by selecting Settings->Audio.

Another check with just the Mac is to determine if the Stellar is connecting to the Mac via the mini’s Sound settings. When the Stellar is connected via USB to the mini, can you go into System Preferences → Sound? Is the Stellar listed under the Output tab?

Also have you tried replacing the USB cable between the mini and the Stallar to see if the cable may be an issue, or change the USB port on the mini? That age of mini is getting on in years and you may have some deteriorating components or oxidized connectors.

I discovered the Mac does not see the Stellar connected to the USB. I have not restarted everything in the order you gave or redone connections because the connection are hard to get to. All I did was update the OS software. It was all working right before I told it to upgrade. After the upgrade, other stuff works ok, but not the audio. I upgraded because apple said there was an urgent security issue that required a fix. Somehow that caused the problem.

I find it next to impossible that all of a sudden connectors or cables corroded or that it would have any affect on the router. But for some reason after I updated the OS, it does not see the Stellar on the USB port. It does see an external disk connected on another USB port.

Before I saw your reply, it dawned on me that the Mac may not be seeing the Stellar, because Roon should have picked up that audio device and it didn’t. The Mac sees the internal speakers and the HDMI Samsung TV used for display monitor as audio components, but no Stellar. I have powered it all off and on, but not necessarily in the order you gave. I can give that a try, but I have a feeling it’s something to do with OS “upgrade” instead of a hardware issue.

I feel like I need to call Apple, but not sure I’ll get anywhere with them. They used to provide excellent support, but I’ve been real disappointed the last 2 times I’ve called them (in the last 2-3 years, I don’t call them often).

I’ll try the power on procedure you suggest and see if that makes a difference. It’s worth a try. Might try a different USB port also.

I’ll be pleasantly surprised if any of this gets it working, but who knows. I used to know a lot about this kind of stuff, but as I’ve gotten older, it’s starting to become magic.


David, best of luck, we are here to assist where we can. One last question. Can you check the firewall settings allow exceptions for and per these instructions:

Probably already set, but especially on some of the old Mac hardware occassionally OS updates change these settings. The Mac firewall settings are under System Preferences → Security & Privacy, then select the “Firewall” tab, key in your password and go to Firewall Options. The two settings for Roon and RAATserver should “Allow incoming connections”.

I went thru the power-off and on, cable disconnect/connect, and no luck. The Mini doesn’t see the Stellar on USB. If the Mini doesn’t see it, then Roon won’t see it either.

I’ll check the firewall, but Stellar connects on USB, not network. The only network connections to Roon are whatever it does at your end for licensing and your album database (like covers, lyrics) over a hardline. I checked the network and it’s working fine. Web browser works fine. Roon also connects over Wifi to an iPad, and that works fine. The iPad see Roon software and connects normally. Of course it can’t play anything except over Mini’s little speaker.

I think I’ve done a pretty good job of isolating the problem to the Mini not seeing the Stellar connected on the USB port. Or it doesn’t know what it is. I tried another USB port, and still doesn’t see it. Less than a year ago I had disk replaced in the Mini and he checked all the hardware and it was ok. I’m 99% sure this is a software problem having to do with the OS update.

I think next step is to call Apple, but I’ve had enough for the day. I’ll give them a call tomorrow. Sure appreciate your quick response and suggestions.


The firewall was off, so that couldn’t be causing a problem. Since this is single purpose machine, I wasn’t too concerned about it, and didn’t know you had to turn it on. I’ll wait until I get the first problem solved before trying that.
Thanks again for your help, David

Best of luck with Apple David. The only reason I asked to check the firewall is that Roon uses the USB ports as a virtual network connection in RAAT Server (I believe), even though it is using the native USB connection. Windows Cores and Remotes have had similar issues recently with some Windows patches.

Please update when you find out more.

Zero luck with Apple other than he admitted it looked like a problem with the OS update. He didn’t go into any details, but said others have had similar problems. He had me try several resets of stuff that have worked for others, but no luck for me. So only option is to wait for Apple to put out another OS update. Who knows how long that will be.

Apple support used to be better. If the first guy in line couldn’t help you, they would pass you up to a real expert. Years back I had email troubles, and the next guy up really knew his stuff. It might take a day or two, but the problem always got resolved. The last couple of times I’ve called, they will not pass you up the ladder. You’re stuck with whoever, and they tend to just do basic stuff like what he had me do. If that doesn’t work, they throw up their hands. I know UNIX is underneath their OS, and you can do a lot with that if you know what you’re doing. But they never go there. It’s frustrating. Not as frustrating as Microsoft, but approaching that!

I can play music manually by loading CDs, so I’m not totally dead, but I’ll certainly miss Roon and how easy that makes it until Apple gets its act together.

If you hear of others with the same problem, let me know.

Thanks, David

David, sorry there isn’t any further progress. We’ll monitor and if any idea or a solution appears will post that here.

David, a few more questions. Is this feeding a Stellar Strata integrated amp or the GainCell DAC? Does the mini see the PSAudio DirectStream device under the Mac’s Sound → Output settings under System Preferences?

The Mac-Mini is feeding a PS-Audio Stellar Gain Cell DAC. I just looked up invoice and it was all purchased 2017, Mac-Mini, PS-Audio Stellar, and other stuff. The Mini and Stellar are connected with Kimber USB cable. The Mac-Mini does not see any PS-Audio device in System Preferences->Sound->Output (no PSAudio DirectStream or Stellar Gain Cell DAQ).


It may be worth reaching out to PSAudio and see if they can help with the mini/GainCell USB connection. Without a verified connection on the mini, Roon won’t see the device either.

Just to confirm, on Montery, you should see any connected DAC in System Settings, e.g., …

You may also want to try alternative cables.

1 Like

Martin, That’s how it used to look before I did the OS security update a few days ago, and it worked fine. It’s been working on Monterey for months, and on previous versions of OS for years. I’ve never had this problem until the recent OS update. It’s something Apple did. I’m convinced it’s not Roon or hardware.

Robert, Good idea to check with PSAudio. Perhaps they can lean on Apple to get it working again.

1 Like

Are you using a USB hub, or USB 3.0 cable to connect the DAC to the Mac?

I’m seeing some reports that hubs and cables are failing to work with the latest update.

1 Like

Martin, I’m not using a hub. It’s a single USB cable. I believe it’s an older style USB cable with the square type connector that goes into the Stellar GainCell DAQ and a standard USB connector into the Mini (not the newer USB 2 or 3). I can’t easily verify this because all the components are in a cabinet and I can’t get to the back of the Stellar. But I looked online at picture of the back of the Stellar and it looks like you’d need what I used to call an old USB printer cable. The square end connectors back in the old days were common on printers. I bought it all as a package from local audio store, so cable is supposed to be high quality.

I could understand a hub might cause a problem, but I find it hard to believe a cable would do so. I know this is an older style USB setup. It’s very simple, about the simplest connection you can possibly make, one step up from old serial ports. I try to keep things as simple as possible…it’s the engineer in me.


There was a bug when Montery was first released affecting USB 3.0 only; I’ve seen a couple of similar reports since the latest security patch (12.5.1).

The problem affected some hubs and USB 3.0 connections. Solutions included using a USB C socket or a USB-FI certified cable.

Hi @David_Salguero ,

You are correct here, if the OS itself won’t see the DAC then Roon won’t either.

I’ve seen USB cables fail at times, so if you have another one around, it would be useful to try a basic non-audiophile one.

Or you can also try to connect the DAC to another PC as a test, just to confirm that this USB connection still works.

If you haven’t tried a full OS wipe, that would be the “nuclear” option to try to get the system back in working order. I would try the above first though.

1 Like

I called PS Audio several weeks ago and let them know MacMini with Apple Monterey 12.5.1 could not see their Steller Gain Cell DAC. It doesn’t see it connected to USB. I’ve not been able to use it to run Roon and play audio files. They were not aware of the problem, but had no solution either. They did tell me it uses USB 2.0, and the cable is USB-A to USB-B (or standard old fashioned USB printer cable). He also said he was using MacMini with their DirectStream DAC and it worked. Of course, I don’t want to spend that kind of money to fix the problem.

A few days ago Apple put out 12.6 update to Monterey OS, so I gave that a try thinking maybe they fixed problem. It was a long shot, and of course, nothing changed. The MacMini still does not see the Gain Cell DAC.

Called Apple support today, explained problem again, and asked if I could install earlier version of OS, in other words, restore back to where I was before the upgrade. I had TimeMachine backup disk from when it worked on Monterey 12.0.1 OS, and you’d think one of the main reasons for doing backups is to be able to restore to previous version if an upgrade failed. At first they said yes, and we started thru a procedure. But then it didn’t work like she expected, so she passed me on to a guy next level up. In the past, when they’ve done that, these guys know their business.

He said no I couldn’t restore from Time Machine backup to a previous OS version. What I’ll have to do is go to a Mac dealer and have them put fresh install of older version. It will erase the disk, but you can get older version of OS installed. He recommended going back to “Big Sur” version of OS which came out before Monterey.

So I plan to take the Mini into a local store in the morning and have them install Big Sur on it. I’ll have them check USB ports as well. Hoping this works and it sees the Gain Cell DAC. If it does, then I’ll have to download Roon, configure it, and then should be back in business. Wish me luck!


Update: I took Mac Mini to a local store (Ribbit Computers) and had them install Big Sur OS and check USB ports. Got it back, and it still didn’t see the DAC.

But I remembered Apple had me reset the PRAM one time saying that can affect USB ports. Since this was new install, I reset the PRAM (it’s on the web how to do that), and it worked!!

Now Preferences->Sound shows the Stellar Gain Cell DAQ as audio output, and I can select it. I could tell it was doing something because the clicks and whatever sounds from Mac came out my speakers.

Should be simple now to download Roon & install core. Downloaded ok, but when I went to put Roon core on this machine and login, Roon said I was already logged into a core!!! I sure as hell wasn’t, so not sure what’s going on. Now I definitely need help from Roon Support.

If anyone at Roon is monitoring these messages, please let me know what to do. Otherwise, I’ll try to call tomorrow or next day if I can find a phone number. Nothing is ever simple it seems. I have a lifetime license, so that should not be an issue. Whatever just needs to be reset at your end.