Trouble after moving music to a different USB hard drive

Core Machine (Operating system/System info/Roon build number)

HP Omen laptop running Windows 10. Intel Core i7-7700HQ CPU @ 2.8GHz. 64 bit operating system and x64 bit processor. 16GB RAM. Roon 1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple Extreme router. Use Cat6 Ethernet connection for music

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Simaudio 780v2 streamer/DAC

Description Of Issue
Just transferred music collection from HDD USB drive to SSD USB drive. Removed old music locations and added new ones for new SSD in Roon settings. All music appears to be accounted for in Roon. Music will start playing but stop randomly halfway through a track. Occasionally I get an Album Has Been Deleted message when the music stops. If I hit play it will start again and I can manually fast forward to the end of the track and play the track at any point.

Music works flawlessly through Tidal.

Hello Kerry,

After deleting your old music locations, did you Clean up your library?

This will help with your database integrity.


Cleaned up 27 deleted files. Let’s see how this works.

Still having the same issues.

Are you using the same USB port as before?


That may be the cause of your issue - it would have been better to edit the path of your Watched Folder in Roon’s Settings > Storage screen. I suspect Roon is still trying to make sense of why the library contents have suddenly changed around.

See here:

Ah, I didn’t realize that the edit feature allowed one to change the storage location. I think I found a fix, though not ideal. Between deleting the old storage location and adding the new one, I cleaned up my library. That got rid of all files associated with the old storage location before I added the new one. Roon no longer seems to be confused. The downside is that I had to update my playlists but I only had a handful so it wasn’t too daunting a task.

Hello @Kerry, glad things are working again! Please let me know if you have any further questions.

I spoke too soon. I’m having the same issue again. Is it possible to just wipe everything and start from scratch? It’s so annoying to have the music keep stopping on me.

Hello @Kerry, we can try a new database and see if the issue still occurs. Please try the steps below and let me know if you get better results!

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

I still seem to be having trouble with my highres files. They stop playing partway through a track and then skip subsequent tracks saying album not found. Do you think this might have something to do with the new SSD USB drive I’m using to store my music?

I did a test on the transfer rate from the USB SSD and it seems normal:

Playback of problematic albums works perfectly through my Moon MiND streaming system, so it’s not a network issue. It has to be a Roon issue.

Yes, same USB port

Hello @Kerry, and my apologies for the return of the issue. Did you have a chance to try a new database as I recommended in my last message?

I did and the issue returned. I’ve since tried it one more time and things seem to be working now. Fingers crossed that it keeps working this time.

Same issue is happening again

Yes, the same USB port as before.

@nuwriy How do I set up a time to go through this issue with Roon support directly? It’s been over a month now and the issue is still not resolved.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.