Trouble connecting Nucleus to Huawei 5G CPE Pro 5 Router for ARC functionality (ref#J0SMN0)

Full form submission

What’s happening?

I'm having trouble with Roon ARC

What best describes your issue with ARC

Can't setup connection with Roon

I have got a new Router, Huawei 5G CPE Pro 5, and can’t connect ARC with my Nucleus. No automatic connection, wich have not been possible with any of my routers by the way, but I have until now managed to figure it out.

Does this article help?

Specifically the “UPnP Service not found” section which the link above should take you to.

Hey @Claus_Hugger
Are you German speaking?

https://telekomhilft.telekom.de/t5/Festnetz-Internet/Huawei-5G-CPE-PRO-2-nicht-von-aussen-erreichbar/m-p/4726497#M1721674

I used this exact router for many years with a Deutsche Telekom SIM card.
Due to various quirks of the device, I decided to operate it in bridge mode and transfer the routing functions including port forwarding to an Asus router connected behind it.
That at least worked perfectly.

No, I have tried to toggle UPnP on and off, manually set the listening port and IP address and restartet everything, same result.

Hi @Claus_Hugger,

Thank you for your post. When you reset the listening port in Roon → Settings → ARC, did you try augmenting by a few thousand? The new router likely has different port range restrictions, and without UPnP or NAT-PMP to relay the router’s port table to RoonServer, Roon won’t have a mechanism to detect an open port.

I recommend checking the port tables in the router administration. You’ll also need to update the port assignment in any manual rules so that it always matches.

When you switched routers, did you also change internet service providers?

Do you have a Fritz!Box or another gateway-style modem unit on front of the Huawei router?

Thank you for answer. No I didn’t change internet provider and I have no other device on front of my router. I have tried to alter the listening port ‘here’ and ‘there’ but maybe not enough, I’ll try a little more. (I am not sure if I do it correctly in the router setting, there are no options like port forwarding or similar).

Hi @Claus_Hugger,

We wanted to check back on this case since ARC diagnostics don’t show a positive cellular connection associated with your account.

Let’s start with the very basics of your network setup:

  1. How many routers are in your setup?

  2. Who is your internet service provider?

  3. If you have multiple routers, where have you connected the Nucleus to the network?

From there, we should be able to isolate and identify the blockage. Thank you!