Trouble connecting Roon App with ROCK

first of all, I am new with Roon. - I went through the installation process by setting up a NUC 10i7FNH mit SSD an 8GB RAM. The BIOS setup took me quite some time but I managed. CODECs are installed. I can access ROCK via my PC browser.
So far so good. When I open the ROON app on PC or smart phone I can see the ROCK. I can select it and end up with the sign-in window. When I enter my account infos, the app cannot connect with the ROCK. After approx 30 sec an error message appears “Network Problem, check connection to the Internet”. Needless to say, that my Internet works just fine.
I turned on SBE1.0 and guest access on my win10 machine. I did reset my network, but the problem stays. Since the android app cannot connect either, the problem must be with the ROCK, I guess.
Any ideas?
Thanks Chris

Hi Chris, fellow user here. You might try setting the router. dns to or and see if that helps.

Hi Dan,
I have a cable modem that works only with pre-configuration. The internal adress is fixed to Thus I cannot change the DNS/Gateway to your recommended setting. I still use for DNS/Gateway, sub mask
I tried static and dynamic IP for the NUC. I did reset the network, but no change.
Any other ideas?

Quick Update. Changed at least the DNS-Server Setting in ROCK to and - ROCK still won’t connect to the internet. Hard to tell if this is a router or a ROON problem …

O.K., I got it to work. It is a connection to the Roon servers issue that can be solved by set the DNS Server setting both - in Windows and ROCK - to Cloudfare DNS ( I tried Google DNS Server ( / as well, but this setting didn’t work out.
Dan, thanks for the very helpful advice

1 Like