Trouble Connecting Roon With Tidal

Core Machine (Operating system/System info/Roon build number)

Roon 1.7 (build 610) 64 bit, running on Synology NAS 218+ DSM OS (linux flavour)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Comcast xFi Gateway (modem/router) Netgear Gigabit Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic Aries G1 connected to switch via TP Link Media Converter Fiber Optic and Mytek Brooklyn DAC+ connected via USB cable to Auralic Aries G1

Description Of Issue

Recently I switched my ISP provider and my LAN IP changed (as with Comcast xFI Gateway you can’t change LAN IP address). Since then I am having trouble using my Tidal account through Roon. I login to Tidal, get a display I registered and sends me back to Roon where nothing happens, still login pop up menu. I stopped Roon, deleted RoonServer/Cache start Roon, try again to login to no avail. Before I switched my ISP provider it worked like a charm, and I have no idea what is going on and it is getting really annoying. I see based on the number of queries in Community I am not alone having trouble with it. How come that you cannot fix the problem?

Hello @Predrag_Kos, can you try changing to google or cloudflare DNS to see if that helps?

Nuwriy, unfortunately I can’t. With Comcast xFi Gateway you can’t change DNS. Comcast DNS 75.75.75.75 is hardcoded in the modem/router firmware. Don’t ask me why, Comcast is doing a lot of things, just because they can. I was forced to switch to use Comcast equipment cause data cap, and was tired paying overage fees. It is not only Tidal. I created Qobuz trial account, configuring Qobuz also does not work. Neither is configuring DropBox. So none of authentication of third party accounts work, which really makes no sense. If DNS propagation was the problem by now (over a week has passed) it should have been propagated already. But that is not the case.

Reboot your nas

I have tried reboot several times, deleted cache, to no avail :hot_face:

Nuwriy, Is that it, try changing DNS server, and good luck?

I’m left on my own to deal with this issue.

Roon as good application as it is is, simply cannot leave such flaw in their software unattended, and expect customers will endure serious bug in the software. What makes it even more annoying is lack of transparency. I can understand and accept simple answer like, yes we are aware of it we are working on it and will let you know when it is fixed.

But not even trying ro help me out. Instead pulling wool over my eyes with " can you try changing DNS server" simply does not instill confidence that company is serious.

Hello @Predrag_Kos, and thanks for checking that. A good number of our community reports similar to this issue have been related to an environmental issue such as network, browser, or firewall. So we can narrow this down and resolve your issue, could you please try the following?

  1. Can you try changing your default browser?
  2. Can you let me know if this issue also happens with a different remote?

Please let me know the results and we’ll go from there!

Nuwriy,

Have changed default browser from Chrome to MS Edge, no luck.

Changed from MS Edge to Firefox, same result, fails.

I am using three different remotes, Android phone, iPad, and lap top, they also have same issue.

Just want to emphasize that my Synology NAS (running Roon Core) is connected directly via CAT 7 patch cable to router LAN port and that Roon Database is on 250GB SSD drive (aas recommended) connected to NAS via USB 3.0 cable. Just to be sure I turned off firewall as well. Again does not work. It connects with Tidal without a problem. Authorizes account, gets to oauthcb.roonlabs.net/2/tidal/authorize… (which I can also ping and if I access it via browser gives me “Hello”, so DNS recognizes your authorization server). Apparently when Roon needs to save the configuration it fails somewhere or somehow :confounded:

Hello @Predrag_Kos, are you able to produce this issue if you temporarily run another core?

Nuwriy,

I installed Roon Core on Windows PC (on the same network using ethernet cable) and configuring Tidal works. But have to advise you that Roon Core version on my NAS is 1.7 build 610, and on my Windows machine it is 1.7 build 667 (not sure whether that makes a difference, just wanted to point it out). However now I can’t log back to Roon Core on my NAS gives me Network error :roll_eyes: What is network error, I can access NAS no problems. What is the difference when connecting from Roon Core on Windows machine to the same NAS, as apposed to having Roon Core on the NAS. Is there anything specific on Roon Core when it is running on NAS as opposed to running on Windows machine. It is so confusing and must admit frustrating. This is happening on the very same network setup, same router, all connected via ethernet cable.

Nuwriy,

In all honesty i do not consider this a solution. I want Roon Core running on my NAS, not on my Windows desktop. Obviously there is some issue with the way how Roon is dealing with things when running on Synology NAS and on Windows. I am probably not the only one trying to run Roon Core on Synology NAS. It is all on the same LAN, connected through a wire, this should be no difference. Alas there is apparently. Can you provide me with proper guidance or hint me how differently Roon Core works when running on Synology NAS so I can continue my struggle.

DNS settings?

But in both cases, Roon Core running on Synology NAS or running on Windows desktop, they use same default DHCP, thus same default DNS server settings. Also router (or NAT) knows whether address is local and routes query accordingly. It does not make sense.

Lo and behold it started working out of blue. :astonished:

I was able to unathorize my Windows desktop Roon Core and login to Roon Core on Synology NAS. Also configuring Tidal and DropBox, went without a hitch.

After closer inspections it does not appear to be out of the blue. Build on my NAS was updated to 667 from 610. Now it is the same as on my Windows desktop version and it is working now.

I wish you the problems are fixed but unfortunatelly they will appear again.
My expirience is exactly the same: Roon core on NAS, DNS predefined at ISR’s router and not allowed to be changed. The problems with Tidal accessibility from Roon appear intermitently every second day.
Unfortunatelly Roon is hopeless with solving this long lasting problem which affects so many users. Shame to Roon, having in mind the price of the product!

Wlodzimierz,
If it plagues me again, regardless how much I really like Roon I will cancel my subscription. That is the main reason why I opted for annual subscription instead of lifetime. Annual subscription equals to 5 years cost of lifetime subscription. As technology progresses so fast, nobody knows what will happen in 5 years and how many different products will be there. As a backup I have Auralic Lightning DS application (which is very buggy and slow, indexing of my library takes about 16+ hours :grimacing:) but it is free, and works for the most part, as I have Auralic Aries G1 streamer.

What bothers me the most is that Roon is so hush about it. I can and will accept answer “we are aware of the problem, we are working to fix it”. Instead they give you all sorts of excuses and make you chase your tail, and then voila fix coincides with the release of new build :rage: seriously!

Roon is really very nice, complex, feature rich product. It is head and shoulders above competition. They really do not need to be furtive about the bugs, it is software, bugs are way of life. Instead they opt to pull wool over customer’s eyes, so disappointing and frustrating.

… by the way, if the problem occurs again one should (at least in my case):

  1. Restart your router
  2. Restart your Roon core (stop and start on NAS).

… and have a nice time with your Roon … till the next freeze.

:+1: thanks for the hint :wink:

That’s always the first step in resolving most problems with Roon. It’s usually related to your network.

Jim,

When you reset router what it does is, maybe assign new IP addresses, unless you have assigned static IP addresses (which I do). That happens anyway, occasionally, as routers do change IP addresses when lease expires (based on the configuration). DNS is the same (in my case it is fixed by ISP). So am not clear how that fixes network issues?