Trouble connecting to Core on Android 10

I have Build 433 of the Roon Remote app, but I am still having problems connecting to my Roon server on a Qnap NAS since upgrading my Pixel 3a to Android 10. All I get is a spinning clock.

I have been able to connect by stopping and starting the server, but the problem still persists when I return to my phone after not using it for an hour or two.

Trouble for me also, on latest version from Play Store (Pixel XL on Android 10). I just get “Looking for your Roon Core” forever - even after a fresh app install.

can connect to my core from my laptop though, no problems.

I have found that if I specify the IP address of the Roon server explicitly in the Android app, then I am able to make a connection. It seems like it needs a nudge to direct the client to the server. This wasn’t the case on Android 9 (Pie).

1 Like

This new app is buggy as hell.on android 9. Completely.frozen on me twice tonight and crashes when in background more frequently.

Thank you @Roger_Cliffe - specifying the IP of the core works for me too.

+1 on that too

Hi everyone,

I spoke with our development team about this and they’ve provided some clarification on why you’re seeing this issue. As of Android 10, Google has instated a policy that prohibits access to the ARP cache. We were using this as part of a last-ditch-effort to make discovery of the Roon Core work on networks where the usual multicast/broadcast based discovery mechanisms are not working.

In cases where this makes a difference, there is always an underlying problem or misconfiguration with the network that is the real root cause of the problem. Fixing the network so that it passes multicast/broadcast reliably between devices will fix the problem. It may also be possible to work around this issue by manually entering the Core’s IP address.

3 Likes

Thank you for this explanation. It makes sense. I use Roon to listen to music at home. I have Netgear Orbi routers/APs for my WiFi. It may be that when I move around the house and the WiFi connection on my phone switches Access Point, something strange happens in the address resolution.

The work around is still working for me.

I really appreciate you getting back on this problem. Thank you.

Thanks the IP address has worked for me, but this will not be obvious to many users so it might be worth making this easier to find

Dear Michael,
I agree, many users will not find this obvious, and quite frankly the millions of Android users deserve better than to have to struggle with the dreaded “looking for Roon Core” endlessly. Roon should give this fix top priority.
Jui

1 Like

My Nokia 7+ got just upgraded to Android 10, and the Roon app failed to find the server.

The assessment that this is due to a misconfiguration of the network is probably incomplete. This particular network is a flat subnet with no restrictions. Note that I am not running a Nucleus; I am running Roon from a NAS (which could be part of the issue).

If you want, I can do some troubleshooting in my network to see if we can nail it down.

usual multicast/broadcast based discovery mechanisms are not working.

This is vague. What protocol are we talking about here, except the ARP issue?

Finally, can I suggest that you update the Roon Android app on Android 10 to notify users of this potential problem when the Roon server cannot be found?

Android 10 works fine. Mine does.

That doesn’t really help, Ged. It’s clear that most of Android 10 works, or the fallout would have been much larger. Still, the issue is real and it would be good to at least have a workaround that a normal human being can understand.

A post was split to a new topic: Connection issue with Android remote

A post was merged into an existing topic: Connection issue with Android remote

My OnePlus 7 Pro was updated to Android 10 a couple of weeks ago, and afterwards Roon would just spin while trying to connect. I tried uninstalling/reinstalling the app, but no joy. In another thread I saw something about IGMP proxying. My router (Orbi) had the option “Disable IGMP Proxying” checked by default. Unchecking this fixed the problem.

3 posts were split to a new topic: Cannot connect to Core - Manual IP connection

How do you spesify the ip on roon?