Trouble connecting to NAS

I’m new to Roon, but have had it working nearly perfectly for the past few days. I think the Core had just about finished analyzing my library. Now the only tracks that show up in my library are from Tidal. I have about 23K tracks.

I’ve got the Core (1.3) running on a sonicTransport i5, connected to a microRendu feeding a Musical Fidelity M1 DAC. The library is on a Synology NAS. All are connected via ethernet, no wifi.

I can browse the library from my MacBook Air with no trouble. I restarted Roon, resarted the sonicTransporter, and restarted the NAS, all to no avail. When I go to settings>storage it says directory not ready.

I’ve been searching the support forum, but nothing I’ve tried
has worked.

Thanks for your help!



Might this apply?

Yes and no. That says it only applies if you have some internal storage, which I do not. However, after reading that post about 10 times, I decided to give it a shot and tried to edit the storage location. Re-selected the folder where my music is stored on the NAS, and it looks like I’m reconnected. Seems like it’s reimporting my library from scratch. Works for me, I guess.

@kneville - Thanks for taking the time to point that out!

1 Like

It’s rescanning my main music folder, but I still can’t seem to force it to connect to the another folder on the same NAS. Frustrating.

@agillis - any thoughts?

Could this be the cause?

With luck, although it is rescanning everything it should only have to completely analyse what was missed the first time so this should be a much faster process. Fingers crossed!

Yup. Did not need to reanalyze.