Trouble connecting to Remote Core on Android 11

Core Machine (Operating system/System info/Roon build number)

Core Machine runs on a Windows 10, but I have also tried on OSX Sierra.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Linksys EA7500 Router connected to an unmanaged switch (Netgear G5324). Core Machine connected via the switch, Android phone connected via eero, running in bridge mode connected to the unmanaged switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Port

Description Of Issue

When I try and connect on my Android 11 Pixel 3, I am stuck on “Waiting for Remote Core”. On iOS devices, I can find the Remote Core no problem. If I toggle “Accept connections from remote” on the Core Machine, I will instantly connect on my Android 11 device.

From reading other support tickets, I suspect this issue is due to Google’s policy that prohibits access to the ARP cache, which points to an underlying network issue. However, I’ve tried several suggestions from support to no avail.

Would appreciate any help. Thanks!

It’s a very common issue. Temporary try thiis.

That’s odd. I don’t see a place to enter my IP address when I press help…

Is there a timeline for the fix, or something I can do on my end?

Can you share a screenshot of what you do see here?