Trouble getting PC-USB to show up as end point

2017 Macbook Air remote, and pc-usb output
Nucleus+ core
Rotel A12 MK II endpoint

When I plug the usb from the mac to the Rotel, I then go into midi settings and select the usb as output, then test the speakers, so im getting static test sounds out of each speaker, but cannot get the Rotel to show up as an endpoint under audio settings on Roon.


TIA :slight_smile:

This should help. Nucleus USB out to Rotel USB in, control via Mac WiFi?

Are you using the correct USB input on the Rotel; the one round the back not the front panel?

It isn’t clear if you have the Rotel working with the mac audio on its own (ignoring Roon).

Also make sure you have set the usb audio type to 2.0 in the Rotel Setup Menu

Hi, I’m plugging the USB into my Macbook, which is not a core. Maybe that’s the problem, is there no way to do PC-USB from the actual PC if you’re using a Nucleus as the core and the Macbook as basically a remote? That would explain a lot, and mean that I’m gonna have to get a Looooooooooong PC USB cable.

Yes the PC-USB in the back, which has the squre terminal not the rectangular.

I’m going to try from a raspberry pi USB to the PC USB next.

Thanks I will try that. :slight_smile:

Checking the obvious again, but you do need Roon Bridge running on the Mac for it to show up as an endpoint.

The Rotel needs to be working with your Mac first though (regardless of Roon).

Yes, have the Roon Bridge up and running in the upper right hand corner of the Mac screen. Even with this it is not showing up as an available endpoint, and I hit the reload buttons as well. I turned both the Rotel off and restarted the computer, turned on the Rotel, and then turned on Roon, still no dice.

I thought the Rotel was working with the mac when I went into MIDI setup and checked the speakers, which were getting the white noise signal. And if I take Roon out of the equation just use any old audio source on the Mac like Tidal or Qobuz app?

Thank you so much for your help! I thought I was relatively computer savvy but I learn something (usually the hard way) every day.

And, apropos of nothing, I did not know I would have to become an HP printer repair expert when I started my hospital job :stuck_out_tongue_winking_eye:

Don’t know if this is related but there is a current issue with Macs and USB DAC visibility:

If you go to settings/audio what devices can you see? In theory you should be able to see the Rotel enabled, maybe you could post a screenshot.

From your OP & screenshot you don’t appear to have your core (nucleus) connected to Rotel? The core needs to be connected to your router (preferably with an ethernet cable) & your client (or bridge, Mac) with a usb cable to the Rotel which should be in Audio/settings (enabled).
You then control from either roon bridge app or mobile phone app.
If you already have this setup in place then there’s either a configuration problem with the Rotel or Nucleus (Roon) in which case you’ll need to Post in the Support category where other Rotel users may also be able to help.