Trouble importing library into Roon

The next thing I need is to pass dsd files which I cannot now


What exactly do you mean by “pass” dsd files? If you are trying to simply import them you can do so by following these instructions:


I am holding off on DSD files. I had loaded a subset of stuff into the database and listened for an hour last night and was impressed. I set the rest if my collection to be brought into Room and went to bed. When I got up the computer had crashed. I was able to restart the computer and I tried to open Too but it stops at a white screen with the black semicircle and the moving “equalizer” style lines. It vasilates between hogging 70 and 95 percent of the memory and seems like it’s just crunching. Have you seen this? Is it corrupt? Is there an upper limit

I am still trying to set this up optimally and I need another week or two to asses or Ill have to cancel the trial

How big is your collection? A large collection doing audio analysis can easily take a while and eat up processing and memory. You can test this by going into the settings/library and seeing if audio analysis is going on. If so, try turning OFF audio analysis and see if it returns to normal. If that works, then just turn on Analysis when you go to bed and are not using the system, turn it off when you want to listen to music; repeat until the analysis has finished.

my collection is very large. I am a music collector for about 30 years. It took about 20 hours to load but it all loaded

the bigger issue is that I am about to have to cancel unless I can get an extension

ok I have to cancel sorry it didnt work out

Hey @Ben_Katz,

I split this off into a new thread since the issue with the Marantz device was resolved. This allows for future community members to more easily find threads related to what they’re experiencing.

When you access Roon is this still what you’re experiencing?

How many albums have imported into Roon vs how many you’re expecting?

Additionally, @eric sent you a PM regarding the status of your trial. Please take a look at your private messages here on the forum and let us know if you have any questions!


1 Like


I can now get into the program. It takes about 7 minutes to load, but once it does, it works well

I think I see part of the issue. I have some albums in sacd format, some in wav format and some in ape format among others. I didn’t standardize on Flac until I had already ripped a bunch of stuff… About a year in


I went to reopen Roon after my trial was extended and I’m back to that issue. It been “spinning” for about an hour now. I’m guessing it is crunching my data as if it were new and it will pop out of that spinning at some point. Is that a reasonable assumption? @eric

Hey @Ben_Katz,

Thanks for the update, and apologies for the continued difficulties here. First, I’d like to get a little more information on your setup.

You mentioned previously that your library is quite large, and stored on external drives connected via USB — How large is your library (number of tracks)? What kind of drives are they stored on?

Can you also give us a little more information about your Core machine? What kind of CPU does it have? Is the Core located on an SSD? How much RAM does it have?

For larger libraries it can certainly take the Core machine a good amount of time to perform analysis, during which there may be a bit of slowness. Once you’re able to get back into Roon if you go to Settings > Library you can verify if analysis is being performed. You can also set analysis speed options here. We have a great article about audio analysis in our knowledge base that I definitely recommend checking out!


I have roughly 850,000 tracks. I have 2 year old maybe 3 PC running Windows 10 and external WD drives connected to it.

Thanks, @Ben_Katz.

Can you provide some additional information about the specifications of the Core?

  • Does it utilize an SSD? We definitely recommend using an SSD, especially for libraries as large as yours.
  • Can you provide some information about the CPU in the Core machine?


I don’t have Solid state drives. I can’t tell you more about the PC until roon either boots or crashes because right now it’s a maximized white screen with that icon at the center.

But I dont think the machine is the issue. Once I originally got it to load it worked fine.

I pulled up task manager and roon is taking up .2 percent of the CPU

This isn’t going to work.

I wouldn’t recommend running 100k track library without an SSD, as they are probably the single most important factor for Roon’s database performance. Trying to run 850k without an SSD is almost certainly not a good use of your time.

1 Like

I had been running it pretty well before I cancelled my trial. It takes about 7 minutes to load each time but once it does it hums along

right now the issue is I cannot load Roon at all. Its just hanging. Its inching along in terms of CPU usage so its doing something, I believe, but at .2 percent of CPU usage at most its not taxing my system at all @mike

I should be clear. I have already scanned and loaded most of my collection. It not scanning files at the moment its just trying to load.

wait I do have an SSD boot drive. what I don’t have is SSD external HDs

Thank you for the clarification, @Ben_Katz!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Update — The diagnostics report has been received and passed along to the team.