Trouble installing

Roon is the biggest load of junk I have ever encountered. I have downloaded the free trial, and spent the afternoon failing to run it. I have a MacBook Air running Sierra. Roon is on Finder and puts an icon in the dock. When I click on the icon it won’t launch. I have tried all the fixes recommended for changing the OSX permissions, and nothing works. It just keeps circling back to a message that tells me when it was downloaded. I HATE YOU AND ALL YOUR WORKS.

1 Like

I’ve shifted your post into its own Support thread and notified Support staff. I’d like to help myself, but don’t know Macs well enough to know what is wrong. It may be that other Mac users can assist.

@John_Brigg I assume you followed the instructions on exactly?
I have just installed it on my MacBook Pro running High Sierra and it worked first time.

I have a quaint old fashioned view that the people who sell the software should support it, and should not rely on the goodwill of their put-upon users. (Or maybe they should design stuff that works in the first place.)

People here voluntarily help they are not put upon, reading your other post reminds me ‘you never get a second chance to make a first impression’

Hi @John_Brigg ---- Thank you for the post and sharing your feedback with us. The insight is appreciated and sorry to hear of the troubles here.

As @Ratbert has done, I just did a quick test to confirm that there are no issues with the install process on OSX via my MacBook Air. The application downloaded and installed as expected. In light of this may I kindly ask you to please provide us with the following information (see below) so we can try to understand what could be causing you to have a different experience. Thanks!

  • Please briefly outline the steps you took when you were trying to install the application on the MacBook Air. As asked previous, were the directions listed in our Knowledge Base used during this process?

  • While it may seem a touch elementary, have you tried rebooting the MBA to see if the application can be launched after the devices powers back up?

  • Are you running any antivirus application or firewalls on the MBA that could be blocking the install process?


Is this a serious post, surely not?

This comes to mind…


Hi @John_Brigg ---- I wanted to reach out to see if any new observations or progress has been made in regard to getting the application installed on your MacBook Air. The support team is standing by ready to help so please do let us know if we can be of assistance.

Many thanks!


Thanks for your helpful emails. Your soft answers have turned away a whole heap of wrath, and I apologise for my outburst in the User Group forum.

I don’t know what I was doing wrong before, but I followed the instructions in exactly, and it loaded and ran. (I did not know about these instructions before your email - see below.)

My difficulty now is that I cancelled my free trial membership, and it won’t allow me to start another one. I have asked for the membership to be reinstated, but to date this has not happened. I would appreciate it if you could expedite this for me @eric.


I have been giving some thought to what went wrong, and how you can avoid these problems with new users in future:

My problems all started because I did not not know of the existence of the installation instructions above, or that there was a Roon User Guide.

I started by Googling “download roon”. RSS01 shows the resulting screen. You will see that the installation instructions are not on this screen. You have to scroll down one level to find them, as shown on RSS02. I did not do this. Instead I started from what I thought was the obvious place ie the top URL : Roon Labs: Download. All the screens which follow this one do not have installation instructions on them, and do not mention the User Guide. I do not want to waste your time with further screen shots, but the screens go:

  • Options to buy or download the free trial
  • Sign up
  • Directions to the Knowledge Base or User Forum/Support group.

I know the people on these forums are volunteers, trying their best to be helpful, but they are not an efficient way of transferring information. I spent a whole afternoon scrolling through suggestions, and ended up very frustrated when none of them worked.

It would be much better if your opening Download screen said in large letters at the top:

If I had had this info at the start I would have been a happy camper.
By the way, I have never posted on a user group before, and have no idea how to flag anything @Support. So you lost me there as well.

(Message to @ged_hickman : we all have to start somewhere.)

I will let you know how I fare once my membership is reinstated and I have managed actually to run Roon.

Regards, and thanks again.

RSS 01.jpg
RSS 02.jpg

1 Like

Hi @John_Brigg ---- Thank you for reaching out and providing me with an update. Good to hear from you.

I wanted to let you know that our accounts manager has reopened your trial period and has sent you a confirmation message via your e-mail. If any other issues come up with Roon kindly open up a new thread, drop a flag for support in your post (i.e @support), and the team will gladly lend a hand.

All the best,

Hi @eric Roon is now working fine. Thanks for your help and patience.
@Ratbert Thanks for your support
Thanks to KP for extending my membership (Sorry I can’t say your name out loud, because Roon won’t let me.)
Now for the next phase:
Does anyone have experience of running a LANRover on Roon? Mine won’t produce any sound. Apparently this is caused by Roon setting the frequency back to 44.1kH, which LANRover doesn’t like. Any way to stop Roon doing this? I can set the frequency to 384kH via Mac Audio MIDI.

1 Like

You can upsample in Roon. Is that what is required? I am not familiar with the LANRover

Yep I’ve had the LANRover with Roon. Do you have Exclusive Mode enabled? To get around the issue, try setting the sample rate in Audio MIDI to 192kHz and set Roon to up-sample to 192kHz, you might be ok. You might be able to try the at 384kHz. It takes some fiddling.

It’s a known issue (not just with Roon).

LANRover has been discontinued.

1 Like

Thanks for replies @Tony_Reimann and @dabassgoesboomboom. Unfortunatley I have tried all those things, and nothing works. The system remains stubbornly silent as soon as the LANRover is put in the loop. I am going to have to return it.

1 Like