Trouble loading TIDAL content

How solve this problem?
Still lasting… in me

Hi @Hansaem_Lee,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you elaborate on the issues you’re seeing? Is it just loading TIDAL albums? Are you able to log in to TIDAL in Roon at all?

have you tried rebooting the Core machine since experiencing this issue?


I can log in to TIDAL after the nucleus software update, but i can’t play music of TIDAL.
I always can see “Error loading page” , It’s annoying me very very. How do i solve this?
I tried core rebooting & core re-installation but problems still lasting.
My network : ipTIME A3004NS BCM -> Sotm sNH-10G -> Sotm sMS-200Ultra / Nucleus plus for roon core.
I tried Google DNS server ( in my Nucleus plus but “Error loading page” still lasting.
The more updates you make, the less you get at TIDAL. It would be better to go before the update.
And I am old Korean. It is really hard to express it in English.T.T

Hi @Hansaem_Lee,

Can you verify that the Nucleus and all of your remotes are up to date?

Does the same behavior occur if you play to System Output of a remote instead of the Sotm?

Does local content play okay?

Local contents play is ok.
Same problem occurred in other system output of my remote.
After latest update of nucleus I can not play tidal music track.

Hi @Hansaem_Lee,

If you go to Settings > Services > TIDAL and lower the streaming quality does the issue go away?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.