Trouble Logging in at ROCK

Core Machine (Operating system/System info/Roon build number)

ROCK (Roon recommended Intel NUC) version 1.7 hardwired to Cisco switch
ROCK webinterface shows OS = OK, Server Software = OK and Database and Settings = OK

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology NAS hardwired to Cisco switch
TP Link Archer router connected to Cable Modem

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

ALLO Digi One Signature streamer hardwired to Cisco switch
ALLO Volt, ALLO Boss and HiFiBerry AMP2, all WiFi endpoints

Description Of Issue

Experienced difficulties with new Ropieee installs on the WiFi endpoints. Especially the HiFiberry Amp2. After several restarts of the Intel NUC based ROCK, I suddenly needed to login. This takes ages and finally fails, due to ‘network error’ warning. I checked the internet connection and it happily downloads at 50 Mbps and uploads at 25 Mbps. All software is up to date right now.

Before the log in problems started, the HiFiberry endpoint showed up in the Roon settings but not under the audio tap.

In the mean time, I’ve tried many things but the bottom line seems to be it doesn’t connect to Roonlabs to validate the subscription.

I’ve also reset my password. This is accepted, but I can’t log in. At some point it directed me to do a new set up, which I declined since I don’t want to lo lose settings, favourites, playlists etc.

On my side I’ve restarted just about everything. Truly hope somebody has a solution.

Thx, wim

Hi @Wim_van_Slooten,

What kind of Cisco switch are you using? Is it a managed one or an un-managed one?

Managed switches have caused issues with Roon in the past since they need to be properly configured, can you try to connect you ROCK directly to the router or to an un-managed switch to verify if the issue is the same?

Networking Best Practices Guide - Managed Switches:

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Hi Noris,

Thanks for having a look at this issue. Just checked your solution by connecting ROCK directly to the router. Logging in problem still the same.

I have a feeling that due to all the restarts, some of them hard by shutting down the power on the NUC for a couple of seconds and than a startup, the Roon server software has been damaged.

I could restore from the backup, it has been backing up right up to this day, but am afraid it could also restore the logging in problem.

What would be the best course of action?

Hi @Wim_van_Slooten,

Can you please access your ROCK logs by using these instructions and send me a set? The logs I am looking for would be under Data/RoonServer/Logs, if you don’t have Dropbox / Google Drive to send these over, just let me know and I can provide an alternate upload location.

Hi Noris,

Just zipped the log folder. Can you give me alternative upload location?


1 Like

Hi @Wim_van_Slooten,

I sent a link via private message, please let me know when the logs are up so I can check the folder, thanks!

Log folder has been uploaded. Thx, wim

Hi @Wim_van_Slooten,

Thanks for sending those logs over. I took a look through them and I am seeing quite a few web exception without response: : System.Net.WebException: Error: NameResolutionFailure errors.

How do you have your router’s DNS servers set up? We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS.

Can you please give this a try and let me know if it helps?

Hi Noris,

My primary DNS is indeed ISP provided. I’m willing to change this, but in the past I’ve never experienced problems with this. ROCK worked perfectly from the moment I installed the NUC October last year. Why would the ISP provided DNS suddenly geive problems from one moment to the next?

Thx, wim

Hi Noris,

Just changed the DNS to Google’s. Still no logging in…

Same with Quad9…

Hi Norris,

I’m now without Roon for a full week. Should I try a reinstall and restore from my backup?

It can be me, but something seems wrong with the ROCK software. This is what happens when I start the Roon app on my Powerbook:

  1. I start the Roon app and I need to log in to my account.

  2. Logging in hangs, so I click on the dimmed section of the screen.

  3. I now have the option to use Go Back in left upper corner

  4. I can now choose my Roon Core which states to be ready and I Connect.

  5. Message: Are you online? I have the option to retry.

  6. Next screen in the left upper corner there is now the option to Log Out. Which is funny, since I wasn’t logged in. I can add also add music, which I don’t since the app is seeing my NAS music partition. I’am able to Continue and can…

  7. add a music service, which I don’t cause I already have Tidal.

  8. Now I can Setup audio devices. I have quite a lot, but none is available.

  9. I can Finish, but there are no audio devices. Not even my Powerbook is available.

If possible I would like downgrade from ROCK version 1.7

In the mean time I did a re-install of the operating system and a reboot. Still no logging in.

Anybody out there with a solution?

Hi @Wim_van_Slooten,

Can you please share a screenshot of your ROCK’s Web UI? I wonder if you have accidentally configured a static DNS there.

Hi Noris,

It’s configured DHCP. Just sent you a screenshot.

Hi @Wim_van_Slooten,

Where have you sent the screenshot?
I am not seeing it on my end.

You may also want to try an OS reinstall from the WebUI to see if this helps:

Here’s the screenshot and I already did an OS reinstall from the WebUI. Same problem, logging still