Trouble Playing Chromecast Audio

I have a Chromecast audio group consisting of four RIVA Wand speakers with Chromecast built-in and one pair of bookshelf speakers connected via a Chromecast Audio device. Too often, when I play the group, the group icon shows music playing but no music comes from any speaker. If I reboot, my Innous Zenth MKII music server, which hosts Roon Core, music plays. Generally, I have to reboot my MKII first thing in the morning to get the Chromecast group to play.

I have a second audio group consisting of a NAD M12 RAAT pre/dac and Raspberry PI RATT Bridge connected to the MKII and it plays without fail.

Hey @Johnnie_Pearson,

It sounds like you may have a networking issue and multicast is going wrong somewhere. What is the model/manufacturer of all of your networking gear? Does your network follow our Best Practices Guide? I would also check to see if your router has the option of IGMP Proxying or IGMP Snooping as those have helped in the past.

Thanks,
Noris

To answer your questions:

WAN and DHCP Server - Verizon FIOS Quantum Gateway Router
WAP - Netgear Orbi RBR50 w/ 1 Satellite. The Orbi uses one SSID for both the 2.4GHz and 5GHz networks.

Roon Core is hosted on an Innous Zenith MKII, which is connected via Ethernet to the Verizon router.

  • The media library is stored on the MKII.
  • There is a Netgear switch in front of the MKII

All Chromecast devices connect to the Orbi WAP, which is connected to the Verizon router via Ethernet.

From what I can gather from Internet research, IGMP Proxying and IGMP Snooping are not Orbi setting options.

Hello @Johnnie_Pearson,

Thanks for letting me know that information. Do you by any chance have another computer that you can temporarily host the Roon Core on to see if this same behavior occurs on it?

If you do, I kindly ask you to make a Backup for your Innous Core and then download Roon on your PC and authorize it as a Core for this test, switching between Cores should be relatively painless and will give us a good data point to have.

Thanks,
Noris