Trouble restoring Roon backup on second setup

I have the same issue. I backup at home and try to restore in my weekend house. It brings the message: Restore failed. Please check your backup folder and try again.

At home I have a i5 Sonic Transporter. In my weekend place a NUC i5. Both running 1.5(339).

Backup reports no issues, so I assume there is nothing wrong with my dropbox drive.

This was already happening with 1.3, but I thought I wait until some updates come. It still does not seem to be solved.

During restore, I can see the backups, I can choose one, but after that it fails. I disconnected from dropbox and set it up again, but that did not help.

Any idea?

I found this in the log, with a browser on my dropbox.

One strange thing I noticed, looking in Roon, I only see 2 directories

In dropbox, I see 3 directories. 2 with the same name. Could that be the problem?

Hi @mjazz ---- Thank you for the report and sharing this observation you have made with us. The feedback is appreciated! I have went ahead and split your posts out to a new thread so this behavior can be addressed with you directly.

Moving forward, may I kindly ask you to please verify the following information for me:

  1. Are you able to restore one of these backups using the same steps on the SonicTransporter without issue?

  2. Are you able to create and restore a new back up on the NUC i5 without issue?

  3. When you are trying to restore from the backups saved to your dropbox on the NUC i5 are you performing this action from login screen OR are you logging and then trying to restore from the “backups” tab found in “settings”? During your troubleshooting have you tried both of these methods?


Hi Eric
thanks for the quick reply. A short update.

I was able to make a back up from the NUC to drop box.
After setting up the back up in roon, it came back a couple of times that the directory could not be found. After 2 minutes, I tried again and it worked. There seems to be a glitch by finding the directory in dropbox. I was able to choose the directory, but it still said that the directory was not found.
Back up of library took 26 hours.

Restore of the NUC backup from dropbox worked.

ad 3)
Restore from my home backup still does not work. Neither from Settings nor from login screen.

As soon as I am home, I will try your point 1). If that doesn’t work, I might delete the complete backup from dropbox and start over. Or do you want to have a look at it to find the main cause?

We are now coming things closer. I am not able to restore at home from the i5 Sonic Transporter either.
“Restore failed. Please check your backup folder and try again”

I is currently not possible to add a screenshot, you seem to have problem with your Redis settings.

The strange thing is that in Dropbox I see 3 directories, from Roon only 2. 2 directories have almost the same name, one starts with a dot (.).

No idea, if there must be one directory or more.

Shall I delete all directories and start over with a fresh backup? Or is there a way to find out which directory is corrupt?


Thanks for getting in touch @mjazz and my apologies for the delay on my side. The additional feedback you provided is very appreciated!

Before we go about collecting diagnostics and reviewing logs I have placed a feedback request with our tech team to see if they have any thoughts on this behavior you have reported to us. Once the team has fulfilled the request I will be certain to share their thoughts with you ASAP.

In the meantime, I have a few more questions regarding these recent troubleshooting exercises you have performed. Kindly see below, thanks!

  • Just to be clear on this observation:

    The strange thing is that in Dropbox I see 3 directories, from Roon only 2. 2 directories have almost the same name, one starts with a dot (.).

    • When you look at the RoonBackups via dropbox you are seeing the 3 mentioned directories (.92f0ca … / 92f0ca… / d9464ac…) and when you are in Roon you only see 2 of those directories ( 92f0ca… / d9464ac…), correct? Furthermore, during your troubleshooting you have tried testing with both, correct?

    • The .92f0ca … seems like some kind of reference file to me, hopefully the tech team will be able to confirm or deny that theory. Will let you know.


Hi @mjazz ----- Thank you for your patience here, appreciated! Our tech team has reviewed my feedback request and have asked me to gather the following materials to help aide in our evaluation of this behavior you are experiencing with your backups. Kindly see below. Thanks!


  1. Please try to restore a backup from your dropbox on the Sonic Transporter.
  2. Take note of the time when it fails to restore.
  • Once the issue has been reproduced and the time has been noted I will go ahead and enable diagnostics on your account so our team can have a closer look into this issue.

Backups for testing:

  • Our techs would like to test with your backups in house and as such have asked if you could please send us over a copy of your backups. Since the backups are on your dropbox I believe they can be shared with us via a “shared dropbox link”.


Normally I choose the folder RoonBackups.
I now tried the 2 folders below this, in both cases it found my latest backup. But I was not able to restore it.

Following happens:

  • Confirm restore
  • initializing
  • preparing
  • restore failed (this happens right after preparing)

I noticed, if I start a backup to dropbox, it first states “Migrating”. I saw this a couple of times already.


Please let me know to whom I should send the backup-link.

Thanks for getting in touch @mjazz! You can send the link to me in a PM.

Were you able to also reproduce the issue and note the time of day when it occurred?


In this screenshot of the log file you see the exact time I tried to restore today.

Thanks for the follow up @mjazz! Confirming that I have seen your PM and have sent it over to our tech team to retrieve the backups. Once the team has downloaded the content I will be sure to follow up so you know they have it.

Secondly. Now that I know when the error occurred I have went ahead and enabled the mentioned diagnostics on your account,. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our severs. I will confirm when the report comes in.


The report came in almost instantly. I checked our severs after typing the above and it looks like we have it. Passing everything over to the tech team for review/evaluation.

Once the team have updated your ticket I will be certain to share their thoughts/findings with you in a timely manor. Your patience during this process is very appreciated.

Hi @mjazz ---- Just letting you know that I have followed up with again via our PM conversation. Thanks!


I started a backup to my “downloaded” dropbox backup.
First thing that shows is “migrating”

Rest follows