Trouble starting Radio

Continuing the discussion from Roon Radio Problem:

I am using the latest distributed Roon and Qobuz versions. Roon Radio used to work with Qobuz streaming until last week or two. No changes in computer system. Qobuz recordings stream. Server is Innuos Zenith SE (using version InnuOS version 1.4.2, latest version). I’ve changed no settings, but Roon Radio is now limited to library and does not come up automatically. Network is fully functional as attested to streaming from Qobuz through Innuos->Chord M-Scaler->Chord Dave. I’ve contacted Qobuz, who have no suggestions about this.

How do I re-establish Roon Radio streaming from Qobuz and not limited to Library? It previously worked for 5 months and support is silent on the matter. Roon otherwise setup just fine, no settings changed, as I said, so please don’t ask me to go to installation topics.

I am a lifetime subscriber and I suspect that something is going on with Roon-Qobuz interactions at the Roon server level (i.e. your end).

Thank you.

Bill Perkins

Thank you for taking time to reply. I set toggle to yes (see image 1)


and when the end of the queue is reached I get an error message

stating Unexpected Error Limiting Roon Radio to library (image 2)

This all worked fine 2 wks ago and I haven’t knowingly altered any settings and I’ve also re-examined all settings. Nothing obvious here.

Love Roon Radio’s suggestions streamed via Qobuz, else it wouldn’t even be on my radar.

Hi @bill_perkins,

Does the same behavior occur if you start Radio directly from an album rather than letting it start after the queue is finished?

Hi Dylan,

Thank you for your response. I don’t know how to start Radio
directly from an album. Things seem to be working now, although it is a
bit different. I am prompted to give a thumbs up or down in a queue. I
used to listen to the suggestion and then decide whether or not I liked
the suggestion.

Radio is still not pulling in from Qobuz. Pulling exclusively from my library. Limiting to Library is not selected. Please help me out here.

Can you play anything from Qobuz?

Hi Ratbert,


I’d like to play Roon Radio without starting an album to see if that is working OK. I typed in Radio and Roon Radio in Help for Roon and there are No Results Found. How do I start Roon Radio directly? Is there any way to have it avoid my library?

Thank you.

Hi @bill_perkins,

Can you try starting radio directly from a couple albums and let me know what you’re seeing? You can do this by navigating to an album and selecting the dropdown arrow next to play and pressing Roon Radio:


Try this with a couple albums and let us know if this works for you (and please include what albums you’re starting it from).

Working fine. Started with John Lennon Power to the People and went seamlessly into Qobuz (McCartney, Stones, Springsteen). I guess I was confused that Roon Radio at the end of an album seemed to always go to content in My Library (>3,500 albums). The other glitch of giving an error at the end of an album spontaneously resolved earlier this week without any changes on my end. You folks and Qobuz must have worked some digital (?coding) prestidigitation.

Thank you for the great support.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.