Trouble streaming to Airport Express

Hi! I am a new user. My Apple TV appears on the networked section of the Audio Setup screen. However, my Airport Express Optical devices do not appear. How do I get my Airport Express devices to appear too so I can use them with Airplay?

Hey @Brett_Bachman – sorry for the trouble. Can you tell us a little more about your setup and network, as described here. It would also be good to know the model and version of your Airport Express devices.


[This ][1] is the airport express I am trying to use.

It is connected using Wifi over 5G. It has a static IP address.

My Apple TV which is working, uses the same 5G wifi network.

My server is a macbook pro. It is running MacOS 10.11.1

My Apple TV and the Airports all appear in iTunes when I play from there.

In Roon, all I see is the Apple TV.

Roon 1.1 (build 70)

What else do you need to know?


I have a somewhat similar problem in that my DAC (by La Rosita) doesn’t show up in Roon. AirPort Utility shows it as “AirPort Express version 7.6.4”, which should be current, and it is in the same wireless network as the rest.

I can AirPlay to the DAC from my iPhone, iPad, iTunes etc… My workaround with Roon has been to select “System Output” and then selecting the DAC as the Output Device.

I use a Mac Mini (Mid 2011, 2.3 GHz i5, 8 GB, El Capitan). There has been no change with different Roon builds (using build 70) or OSX versions.

Roon does show one Network device, a Boxee Box, and that showed up automatically.

Any ideas @mike?

Hey @Brett_Bachman, can you describe your network in a little more detail? I gather you have a few Airport Express devices, and an AppleTV --what model is your primary router? Is the firmware fully updated?

@Brett_Bachman @jvall – I’ll be in touch with you both via PM in the next 24 hours with another question or two, and some instructions for sending us logs, so stand by.

In the mean time, @jvall, it would be great to get the setup and network information I’ve asked for above, which is detailed here.


In addition to the previous, my network consists of:

Buffalo WHR-600D (802.11n)
TP-Link TL-WA854RE (Range Extender, Wireless-N)
ZyXEL GS1100-16 1000Base-T (Unmanaged switch)
Cisco EPC3825 (Cable modem, WLAN off)
Netgear Stora NAS

Latest firmware on all.

Also using Roon on ipad Mini 2 (iOS 9.1).

Hi @Mike, thanks for your help. So you have all the information in one place:

My Setup
My server is a macbook pro 17" mid 2010, 8GB SSD. It is running MacOS 10.11.1.

Roon 1.1 (build 70)

Media is stored on a NAS (network details below) which is a RAID 5 Synology 5-bay DS1511+ in iTunes Media Apple Lossless format.

The Issue

My Apple TV appears in the networks section of my Audio setup screens, but my Airport express does not. Currently I have one Airport device and one Apple TV device active on the network.

This is the model of the airport express I am trying to use, its firmware is up to date.

My Apple TV and the Airport Express all appear in iTunes when I play from my macbook which is the server. The also both appear on my iphone and ipad when I play using itunes from those devices.

In Roon, all I see is the Apple TV.

Network Details

My router is a Pakedge RE-2 running 1.18, the latest version of their firmware.

There is a CAT6 cable running from my router to a Wifi Access point which is a Pakedge W7, running the most-recent version of it’s firmware, V1.17.

My NAS, described above, is connected with a CAT6 cable to a switch which connects by another CAT6 cable to my router. It has a static IP address.

My MacBook Pro, the Airport Express, and my Applce TV connected on the same SSID by 5G to the W7 using DHCP.

I tried changing my Airport Express to a static IP, and it still did not show up in the Roon networked device list.

Anything else you need to know to debug?


Hi! After further research and experimentation I was able to get the Airport Express to appear finally. But it takes much longer for it to appear, like 10+ minutes. My Apple TV always appears immediately.

Any idea why it is taking longer to appear?


Hi @mike!

Over the weekend I spent many hours trying to characterize the Airport Express problem. Here’s what I’ve found:

  1. The Airport Express will eventually show up in the networked devices list, but it takes many minutes to appear.

  2. Once it appears, it will also disappear, sometimes for a long time.

  3. Usually after my computer has brought up the screen saver and no music is playing, when I return the Airport is not there anymore.

  4. I can’t seem to find a reproducible way to get it to appear again. You just seem to have to wait, sometimes hours.

I have given up and am only using my Apple TV for now. It works flawlessly and never has been a problem

Could you please help me get my Airport Express working correctly and reliably. My configuration details are in the previous posting to this thread.



@jvall – can you confirm whether this is the same model that @Brett_Bachman mentioned above?

[quote=“Brett_Bachman, post:6, topic:3134”]
This is the airport express I am trying to use.[/quote]

So you guys know, we’re working off the theory right now that there may be something unique about the Airport Express, and we’re looking into getting one for our QA lab – most of our testing has been done with AppleTV and non-Apple Airplay devices.

We’re hoping to have a device in hand soon, so expect a follow up on this real soon guys. Thanks for all the information!

I think it is, more or less… The DAC is based on an AirPort Express base station, with their precision clock, power supply etc…

As I mentioned a few days ago, we’re looking into some possible issues streaming to Apple’s Airport Express.

Right now, it sounds like @Brett_Bachman is having some mixed results getting it to show up quickly/consistently, and we’ve heard similar reports from one or two other users. @jvall is also having problems using a piece of gear that’s based on the Airport Express.

We’re investigating and will be doing some additional testing soon, but I’m interested to know how others are doing using the Airport Express, specifically the newest revision. If you’re using this device as an Airplay zone, please let us know.


Using an Airport Express with no issues. I can’t recall a time that Roon hasn’t found the device. I am using the device only to stream music to a vintage hi-if that requires RCA plugs for audio input. It is not being used as a router in my setup. I also have two Apple TVs in the system and they have reliably showed themselves to be available. Main audio system is connected directly via AudioQuest Dragonfly to the core computer which is a MacMini.

Other than some recent (Tidal handshake?) issues with build 70 upgrade (now apparently fixed) I’ve been a very happy camper.

Thanks @Bob_Worley – same model linked above right?

That is correct, sir. Purchased within the last couple of months for the express purpose of streaming audio–before I decided to give Roon a try. All of the AirPlay devices on my network popped up during my initial Roon setup and I’ve not had any Airplay issues through the 1.1 build 69 and 70 updates.

I am also using the Airport Express setup as @Brett_Bachman, but never had issues.
But when I read Brett’s initial entry, he talks about the Optical devices. Roon does of course not see what device is behind an Airport Express, only the Airport Express itself.

Hey, @Brett_Bachman, thanks for the feedback.

So how did you manage to fix the issue? What did you change in your network setup, airplay device settings (maybe) ?


I never have gotten it to work well. It shows up from time to time, after long waits. Basically unusable. I currently am waiting for a fix or workaround from you guys.

My Apple TV works fine however.

Any luck reproducing my problem in your lab?

Thanks for the followup!


Yup, we’ve found a few issues here. As of last night, we have fixes in the pipeline for our next release.

Really hoping this resolves the issues we’ve heard about from you, @jvall, and @SVinTO. Let us know how it’s looking once our next release is live, guys.

Thanks all!

I’m not sure which release it was, but the issue is gone. The device now shows on the list of networked devices and has worked without issues for the last couple of weeks. Thanks @mike.

1 Like