Trouble with Phorus PR5 endpoint via Airplay

I’m a new Roon user trying it out for the first time. I installed it yesterday and am having issues with an Airplay endpoint not working and failing to play any audio when I stream to it from Roon.

The Airplay endpoint with issues is a Phorus PR5. I purchased the PR5 new and received it yesterday and set it up as part of trying out Roon. I also purchased the Phorus USB to Ethernet adapter for the unit so that I could connect it via Ethernet and not have to worry about Wifi. The PR5 is running CAP, I read in some other support threads that an early version of CAP on the PR5 would cause issues with airplay, but I believe I have a suitably new version

The Phorus PR5 is advertised primarily as a DTS Play-Fi device, but it also lists support of Airplay and Bluetooth connectivity in addition to the Play-Fi support. I’ve successfully tested it with the Play-Fi app and I am shutting down the Play-Fi app when attempting to get Roon to work via Airplay. Roon sees the PR5 OK (as an Airplay endpoint) and I am able to assign a zone name. Last night during some trials, when I press the Play button on the zone it will go to a Pause button (like its attempting to play) and then after 1-3 seconds it will turn back to a Play button. No sound was heard during those trials. Earlier today I saw that when I press the Play button it would turn to Pause indefinitely, but the music progress slider didn’t update and no sound was heard.

In my trials I was able to get the PR5 to play music from Roon on three separate occasions, once initially, but it hung after I paused and tried a different song. A second time I was able to get the PR5 to play after I used the Play-fi app to confirm the PR5’s operation, then closed Play-Fi and then when I tried Roon on the PR5 zone it worked. With the music still playing via Roon, I then attempted to join the PR5 zone to my second airplay zone and it stopped playing and I wasn’t able to get it working again until several hours later. A third time I was able to get it to play after connecting to the PR5 via airplay from an Iphone, verifying that Iphone audio was functioning and then disconnecting. After I disconnected that one time, then the Roon was able to stream its audio. At that point I repeated the trial of joining to a second zone and had success. However after I disconnected (unjoined) the two zones the PR5 stopped working with Roon again.

I’ve tried repeating the steps of pairing an iphone to the PR5 via normal airplay, confirming the audio works then disconnecting, but Roon still will not play on the PR5. I’ve also tried repeating the steps of connecting to the PR5 via DTS Play-fi and verifying that audio works via Play-fi, then disconnecting, but Roon still will not play. I’ve tried disabling the PR5 within the Roon audio settings and re-enabling the PR5 a few minutes later with no success. I’ve tried resetting the default audio settings (I had tried the fixed volume setting) for the PR5 zone within the Roon settings. I’ve tried these things a number of times in different orders, but I just can’t find a way to get Roon to reliably stream to the PR5. I haven’t had any issues with streaming to the PR5 from an iphone app via airplay. When I stream to the PR5 from an iphone app via airplay, and then press play on the Roon remote on another phone, the PR5 will disconnect from the iphone, I assume because Roon is attempting to take it over. I’ve also tried powering off the PR5 and restarting it on a couple different occasions, but that didn’t help either.

I’ve installed Roon Core on a PC running Windows 10, with an AMD FX 6100 CPU (6 core 3.30 GHz) 16GB of RAM and Samsung 850 Pro 256GB SSD.

I signed up for a Tidal trial and linked that to Roon. I haven’t configured Roon to my music library as I’m just trying to get basics working and explore Roon’s options at this point. Roon did pick up one Album (Hamilton Soundtrack) that’s on the PC where it’s installed.

For endpoints I’m just trying out two airplay endpoints at this time. I have the Phorus PR5 endpoint that’s having the issue and I have a Sony STR-DA1800es receiver with built in Airplay support. The Sony 1800es has been working great so far in my trial runs.

Summary of my network:
I have a closet which serves as a central point and cat6 home runs from various satellite rooms back to the closet. The satellite rooms have their own network switches that serve the devices in those rooms.

*Central pieces (these are located in the main closet)

  • Zyxel C1100Z modem for DSL internet connectivity, WIFI and DHCP disabled
  • TP-Link TL-R470T+ Wired Router, DHCP disabled
  • Raspberry Pi running DNSMasq for DHCP and DNS services, I use static DHCP reservations for a number of hosts on my network. At this time the Phorus PR5 doesn’t have a static reservation, the PC running Roon does have a static reservation.
  • Dlink Gigabit switch that serves as central switch for this equipment and the satellite switches located in different rooms.


  • Ubiquiti Unifi AP Pro AC access point wired to the Dlink Gigibit switch in the central closet

*Satellite segments
**Family room segment (where PR5 is located)

  • Gigibit Ethernet switch ran to Central Dlink Gigiabit switch
  • Roku, Wii, Dish Network, Xbox 360, Xbox 1, Bluray, Sony STR-DA4600es, HDMI switch all connected to Gigibit Ethernet switch.
  • Sony STR-DA4600es AV receiver has a built in 10/100 ethernet switch and the Phorus PR5 is plugged into the Sony instead of the Gigabit Ethernet switch

**Master Bedroom segment

  • Gigabit Ethernet switch ran to Central Dlink Gigabit switch
  • Dish Network, Sony TV, Bluray, Roku and Sony STR-DA1800es connected to Gigabit Ethernet switch

**Theater segment

  • Gigabit Ethernet switch ran to Central Dlink Gigabit switch
  • Sony STR-DA5600ES, Dish Network, Bluray, Squeezebox touch connected to Gigabit Ethernet

**Office segment

  • Gigabit Ethernet switch ran to Central Dlink Gigabit switch
  • PC running Roon Core, Raspberry PI, PC with file shares connected to Gigabit Ethernet switch

I’m looking for insight into what would be recommended next steps in troubleshooting my issue. Does Roon produce log files that are accessible that may give clues to the issue? Is the Phorus PR5 a known device that doesn’t work with Roon? Appreciate any help/guidance on what steps to take next.


Here is a screen shot of my Roon Zones for the airplay section -

Here is a screen shot of the settings for the PR5 -

I did some searching and found the log files location. I’m seeing an exception that I think could be related to my issue, here is a snippet from the log around the exception -

03/02 16:45:46 Debug: [airplay/discovery] Sent mDNS discovery response for DACP server E8476BA4F16D4A77
03/02 16:45:46 Trace: [dbperf] flush 0 bytes, 0 ops in 1 ms (cumulative 0 bytes, 0 ops in 235811 ms)
03/02 16:45:46 Trace: [dbperf] flush 0 bytes, 0 ops in 1 ms (cumulative 0 bytes, 0 ops in 235812 ms)
03/02 16:45:46 Warn: [airplay/rtsp] Exception in RTSP request: System.Exception: short read
at Sooloos.Audio.AirPlay.RTSPClient.<>c__DisplayClass16_0.b__0()
03/02 16:45:46 Info: [airplay] AirPlay device disconnected: AirPlayDevice[DeviceId=00051B245ADE@Family Room._raop._tcp.local, Name=Family_Room.local, Model=Device1,2,3, IPEndPoint=]
03/02 16:45:46 Trace: [airplay] disconnected
03/02 16:45:46 Trace: [zone] Family Room received transport control from endpoint integration: suspend
03/02 16:45:46 Trace: [zone Family Room] Family Room received transport control from Family Room: suspend
03/02 16:45:46 Trace: [zone Family Room] Suspend
03/02 16:45:46 Info: [zone Family Room] OnPlayFeedback Stopped

Not sure how to proceed at this point or if this is anything I can fix via a setting/configuration change?

I would simplify the network path by first plugging the PR5 directly to the switch to eliminate the Receiver as causing issues. Then, I’d try the the PR5 just using WiFi, that way you can eliminate the USB/Ethernet dongle as a culprit.

1 Like

Hello @Kenneth_Ragan,

Thanks for the detailed report, it’s always helpful to have solid information to work with when troubleshooting an issue like this.

I second @Rugby’s suggestion of eliminating the Sony Ethernet switch as well as the USB-Ethernet dongle as the culprit here. As you can see in the logs, Roon is simply seeing the Phorus zone drop off the network. Another helpful diagnostic would be to use a different computer in the house as the Roon Core to eliminate the Core’s network connection as the cause of the issue.


Thanks for the suggestions, I factory reset the PR5 and connected it to my Wifi network. It showed up right away as an Airplay device in the Roon Audio Settings. I assigned it a zone name, but Roon still won’t play to it. After pressing Play, the Pause button appears for a second or two and then it changes back to the Play button. I’ve verified that the PR5 is working good via Wifi on airplay streams sent from an iphone/iphone app.

Roon is working very good via the airplay endpoint built into the Sony 1800es in the bedroom. To help rule out some things on the network, I will try moving the PR5 to the network switch in the bedroom so I can test it via the same network path that is working for the Airplay built into the Sony 1800es.

I factory reset the PR5 and plugged it into the network switch in the bedroom (via the USB to ethernet adapter). This is the same network switch where the Sony DA1800es receiver is connected and whose built in Airplay endpoint is working good.

The PR5 showed up right away as an Airplay device in Roon Audio Settings. I assigned it a zone name, but Roon still won’t play to it. In the current state, after pressing Play, the Pause button stays on the screen indefinitely, like audio is playing, but the time elapsed/remaining slider is stationary. The orange audio signal path indicator is also lit. Below is a screen shot.

That is because the source file is AAC from Tidal and that is considered “Low Quality” just like MP3. The Bit Depth conversion is occurring because Airplay is only 44.1/16, so the Tidal stream is being down-converted to 16 from 24 bits.

Sorry if I wasn’t clear, I understand that down conversion will occur when needed. My intention was to describe the symptoms I’m seeing in case it offers clues as to what is preventing the PR5 endpoint from playing any audio. When I select my DA1800es airplay endpoint I also see the orange indicator and the same down conversion, however the difference is that audio plays as expected. In the case of the PR5, it appears that Roon is trying to stream to it, but no audio is heard and the time elapsed/remaining slider will stay stationary for an indefinite amount of time.

At this point I believe I’ve ruled out the network path as an issue by using the PR5 on the same network switch as the working DA1800es. I’m open to other suggestions, but my next step is going to be installing Roon on another PC and seeing if that makes any difference.

This evening I installed Roon on a Laptop - Toshiba running Windows Home 64 bit, i7 4510U CPU @2Ghz, 8GB RAM and 500GB Samsung 850 EVO SSD.

I linked Roon to Tidal and added the Sony STR-DA1800ES and the Phorus PR5 as two Airplay zones. They showed immediately in the audio settings.

From there, I experienced the same issue where the Phorus PR5 is not working.

In relation to networking on this set of trials, I had the Phorus PR5 and the DA1800es on the same network switch in the bedroom. I started with the Laptop on wifi and verified the DA1800es was working correctly, but the Phorus PR5 was not. I then disabled the wireless on the Laptop and connected it via ethernet to the same network switch as the Phorus PR5 and the DA1800es. The DA1800es continued to work and the Phorus PR5 still did not work.

The Phorus PR5 continues to work for streaming from my phone apps via Airplay directly to it. While streaming to the PR5 from a phone, if I use Roon and select play it will disconnect the PR5 from the stream coming from the phone, so its like the Roon is almost working, it just never is able to get the audio to the PR5.

I picked up a NUC7i7BNH and installed ROCK to replace my core. The PR5 still doesn’t work. At this point I think I am done with messing with the PR5. Happy to donate it to your QA lab if you like.

Instead of using the PR5 I dug out an old Apple TV 3 and am using that instead and its working great.

I really like the Roon setup so far and am going to stick with it and buy a subscription. At this point I need to do more research on what I want to use for additional endpoints. My priority is around the multi-zone features as I’d like to add 4-5 zones and willing to sacrifice on sound quality in order to have a better user experience. One of my concerns at this point (still need to research) is whether I should update the Apple TV system software to the latest version, or if that will give me additional problems with Roon like I had with the PR5. Also need to research if any of the other different endpoints can display album art and play time elapsed/remaining via HDMI to a display like the Apple TV can. I wasn’t even aware that a feature like that existed when I started exploring Roon a little over a week ago, I’m really impressed with this ability and now don’t want to lose that feature if I can avoid it.

Thanks for the suggestions on troubleshooting the PR5, but I’m throwing in the towel.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.