Trouble with ROCK login

As Roon core, I have an Intel PC and ROCK running on an Intel NUC. I use one or the other.
Recently, I could not complete the login process with the ROCK NUC. This is new and I did not change anything in the configuration. I can see the ROCK NUC from any remote device (PC or IOS device) and access it for configuration. I used the option “reinstall the OS” , the process went through but nothing changed.
It does not seem to be a network issue since the login process perfectly works with the PC (same data)
Any ideas ?


This is the error message I get :slight_smile:image
but the network and access to the Internet perfectly work. And again, no problem with the configuration on PC

I added some information. I enter login and pwd, click on connect and the process loggin in lasts a long time before I get the error message I posted : network error

I’ve moved your post across to the Support category of the forum, where it will be seen, and responded to, by a member of the Support team.

For clarification - are you saying that you have two active Cores - one on your PC, and one on your ROCK/NUC? If so, then I’m surprised that you are not seeing a screen that asks you to deauthorize your current Core when you switch across to the other one. It may also be a firewall issue at play here. Let’s see what Support suggest…

Hi Geoff
Thanks for the answer
You are right. When I log on the PC, I have this warning saying that I move my licence and I have to validate. I also used to have it moving from my PC to the ROCK NUC. I don’t have it anymore and I suppose it is because the NUC cannot communicate with the RoonLabs website

It could also be because the Firewall rules on your PC have changed, and are now preventing your PC from communicating with the Roon Core on your ROCK/NUC. The “Connect” screen uses multicast for network discovery of Cores, so that would be unaffected.

Sometimes, a major Windows update has a habit of screwing up Firewall rules - have you had a major update recently?

My PC has been updated with the latest Windows update and it works perfectly. It is my ROCK NUC whichdoes not connect with the outside and therefore cannot validate my licence. Otherwise, I can get connected to the NUC using a PC or an iPad


Can you please share a screenshot of your ROCK Web UI?

Hi Noris
Here it is


Thanks for the screenshot!

I see that you have both a Wireless and an Ethernet option, do you currently have the Wireless disabled? If not, can you try to disable and let us know if it helps?

If disabling Wireless does not help, please use these instructions to send me a set of your ROCK logs, thanks!

Hi Noris
Wireless was disabled
Here is the link for log files

Thank you for your support

3 posts were split to a new topic: Can’t connect to ROCK from remotes

Hi Noris,
Did you have a chance to investigate this problem ?
Thank you

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.


Apologies for the slow response here and thank you again for sending the log files over!

This is strange, I am seeing your RoonServer restart every few minutes, but it doesn’t seem to be triggered by anything.

Can I please ask that you first create a Backup of your Roon database and then try to reinstall the Roon OS via the Web UI?

If that does not resolve the issue, next please try to reset the database + settings on ROCK and verify if you are able to use ROCK without restoring the backup.

ROCK Database Reset

If the system is stable with the fresh database in place, only then try to restore the previous database. Please let me know how it goes!

This is not a local network issue since I can access the Core Roon from a browser. This not an Internet access problem since I use alternatively this Rock server or a Windows PC. Everything work perfectly fine with this PC.
When I try to log with Roon :slight_smile:image
I get this message :image
You should be able to find the log files with this link :
Please let me know if you need further elements


Are you seeing this issue with all remote devices?

Since experiencing this issue have you tried rebooting your Core, remote, and router?

We’ll take a look at the logs you shared, but please note that due to the holidays it will take a little longer than usual for feedback on our findings from the log analysis.


Hi Dylan,
Yes, same problem with an iPad, iPhone or WEB interface.
I rebooted everything many times.
I have the same problem in different locations (main residence or coutryside) with different providers (Orange and SFR).
Once again which seems very strange is that, on the same network, I have no problem with a Windows PC when I cannot get connected to theNUC Rock
Thanks for your support

Hi, @THIERRY_MOULIN, thanks for the info you provided. On one of your screenshots of WebUI, I see that DNS Server is automatically set to, could you, please, try setting Google DNS – and see if that works?



Hi Ivan,
I changed the DNS address to but I still get the same message
Network error - check your Internet connection