Trouble with ROCK login


Thanks for trying the DNS change and sorry to hear it hasn’t helped. Can you please provide some more details regarding your network setup? - what is the model/manufacturer of all your networking gear?

Is ROCK attached directly to your router or is it passing through a switch? If ROCK is not connected to the router, can you try to connect the Core directly to the router and verify if the same issue occurs?

Hello Noris,
As I previously wrote I tried in different situations/locations
I plugged the Core directly into the Internet boxes (Orange or SFR) in both locations
Again, I would be surprised if it was network related since in the same location, plugged in the same switch, my configuration on Windows PC perfectly works when the one on the Rock NUC does not

1 Like


Thanks for the additional info. Did you by any chance test my suggestion of performing an OS reinstall?

Hi Noris,
Thank you for your feedback
I already tried to reinstall the OS without success.
I also thought I could try to reset the Roon database & settings but the problem is that I don’t have any recent backup of my system and that I thought that it would be too risky to perform such operation without BU. Since I cannot access the Roon management interface, I don’t how to perform a backup. Could you tell me how to do ?
Otherwise I think I could replicate the data directory since I can access it through the network and then try a complete reinstall.
Please let me know what would be the preferred way


Happy New Year!

Yes, if you are unable to login, then I suggest performing a copy of the /Data/RoonServer directory, as a backup. Backups created in this way are not entirely stable, but it is better than no backup at all.

If you are able to install RoonServer on a PC and copy the contents of your ROCK Data to the PC’s RoonServer directory, then switch the PC to Core mode, you might be able to create a backup that way. You can also rename the RoonServer directory and leave it on ROCK just to have the fresh database as a test:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder

2 posts were split to a new topic: Can’t login on ROCK