Trouble with TIDAL playback

Similar issues here as well, only since 1.8.

1 Like

It’s terrible for me today. One in every five or so Tidal tracks is ending prematurely and skipping to the next. No problems with Qobuz, my library or Roon live radio. And no problems with the Tidal app, without Roon. This is getting to be extremely frustrating—and judging from the increased number of posts about this here and on other social networks, more common. I had zero problems with 1.7.


I did that many times before arriving at the VPN solution I described in an earlier post. It did not help.

Hey @Toolio,

Thanks so much for confirming what worked for you - it might help other subscribers as well :pray:

I’ve been having the Tidal skipping to the next track problem for the past couple of weeks, since the second-last build of 1.8. It was so terrible the other day that Tidal was unusable. It skipped one out of three or so tracks. I tested at the same time with Qobuz and my local library. There were no problems with either. I was also having no problems playing through the Tidal app outside of Roon.

I had tried just about everything I could think of, including connecting my dedicated core notebook directly to the router, eliminating all switches in the path, various DNSs as recommended by Roon, putting the core in a DMZ, changing from wired to Wi-Fi, fixed and non-fixed IPs, changing endpoints, turning off DSP, increasing the Roon buffer and about 10 other tricks. None worked.

I’m in Brazil with a Tidal Brazil sub. I’ve been using it with very few problems with Roon for years. I have changed nothing in my network. In fact, I have two separate internet providers and networks in my home (one 400 megs, which is the one I usually use, and one 250 megs). Both are totally wired and have excellent speeds to most of North America and Europe, when tested with and other speed tests). So I tried the second provider, which is on its own separate network. Same issues with only Tidal and Roon.

So here is what worked for me. I don’t know why, and I’m not sure I should have to do this. But it worked.

I started running the core notebook through a VPN to a server in Miami. I had no skipping in five hours of listening to Tidal. I then tried a server closer to home, in Brazil. No skipping. I happen to have three VPN providers—PIA, Surfshark and VPN Unlimited (don’t ask). I tried various servers with all VPN services in North and South America. No more skipping with Tidal. For some reason a few wouldn’t allow Tidal to login to my U.S. Qobuz account, so I obviously have blacklisted those. I haven’t had any Tidal skips in two days of many hours of listening. I am not running VPNs on any of my remote tablets. This doesn’t seem to be necessary.

I don’t know why this would work in helping me get rid of skipping with Roon, particularly when I am in Brazil using a Brazil Tidal Brazil account. I would welcome any plausible explanations. Sometimes I use my Roon account in Canada, and I’ll be anxious to see what happens there. However, because of Covid restrictions I haven’t been in Canada for a while, and I’m unlikely to be there soon. For now, I have programmed my core notebook to always use a VPN on boot, and I expect it to continue to work.


Hi @Toolio

Can you try disabling the VPN, reproducing the problem, and then note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

We’ll take a look at the logs comparing successful playback with VPN and the failed normal playback and hopefully it will give us some additional insight here. Thanks!

I can, and will. But it might not be for a few days because a huge work project is taking all my time at the moment. I’ll leave a message here when it’s done.

A post was merged into an existing topic: Playback skips to next track

My sincere apologies for the delay in getting around to this. I finally finished the work project that has left me little time to devote to anything else and did some testing yesterday. Much to my surprise, the Tidal situation seems to have improved without using a VPN. I experienced no skips in several hours of listening to MQA files (the most problematic, particularly the higher bitrate, and presumably larger, files). I will have more listening time this week which will confirm whether this continues to be the case. I have changed nothing in my home network.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

My comment has been misconstrued. My Tidal skipping problem, which existed for at least two weeks with Roon and did not occur with the Tidal app, was resolved by using a VPN on the Roon core. My comment referred to the fact that the skipping finally stopped by using the Roon core without a VPN the last time I tested. In other words, Roon-Tidal skipped for two weeks, then stopped. All of this is detailed in my comments previous to this one, in the thread where I posted. Removing the VPN had nothing at all to do with resolving the issue. For two weeks the VPN was the fix.

Yet you marked it as “resolved-VPN was interfering”. This is not correct.

Topic reopened.

Thank you, can you also please change the title to remove “VPN was interfering” inserted by Roon. As I mentioned already, the VPN was the temporary solution, not the problem. I encourage others to try a VPN if they are having similar problems.

A post was split to a new topic: Roon sometimes skips to the next track without the network problem popup

The conversation has been continued via private message.