Troubleshooting port forwarding for Roon ARC on Ubiquiti EdgeRouter X v2.0.9-hotfix.7 (ref#EQD5BM)

Network Setup

· I use a single personal router not provided by my ISP

ARC Status

· ARC is *Not Ready*

Roon Error Code

· “natpmp_autoconfig”: {“status”:“NotFound”}, “upnp_autoconfig”: {“status”:“NotFound”} }

Have you successfully located and enabled the UPnP or NAT-PMP settings in your router's web UI?

· I've turned UPnP/ NAT-PMP on and ARC won't connect

Select the Diagnostic Keyword or Text String

· Something else

Don't give up yet.

· I'm stuck. I'd like to create a post to ask Roon Community for help.

Describe the issue

Hi I have tried out roon for some weeks now and starting to like it. There's one more thing I need to get working before I´m raedy to go for your life time licence. I have some problem wit the port forwarding to get roon arc to work properly.
I will provide the info I get in roon settings, when trying to connect here:
{
"ipv4_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"84.aaa.bbb.ccc","actual_external_ipv6":"null","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}
}

I´ve got a Ubitique EdgeRouter X v2.0.9-hotfix.7 (latest firmware), I´ve configutated "eth0" as wan-port to the internet and "eth2" is connected to my Synology NAS DS1821+ (internal IP:192.168.1.3)
Link-local IPv6 Address . . . . . : fe80::a1ac:a6e:6e65:3a15%8
When i check my external IP
I get: 84.216.171.16 (ISP: Ownit/Telenor, Sweden Kronoberg County, Vaxjo)

I ́m trying to use port 55000 since that is what you recommend, please have a look at the attached picture to see my router interface and help me understand what I should type in the fields to get it working.

I think I´m mixing up what's source and what's destination and maybe other things in some way here, I can not get it to work. Theres a lot of fields thats possible to fill under the headline/menue" Source NAT Rule Configuration", like;
-Outbound Interface
specify address and/or port
-Src Address
-Src Port

-Dest Address
-Dest Port
-Src Address Group/or Interface Addr


Can you please give me a hint how to solve this, since I´ve already tried to solve this by using your port forwarding guide to set up arc, with no success.

So if you can help me get this working properly, I will be a roon life time subscriber in the near future. :-)


Thanks in advance.

Describe your network setup

ISP-Ownit Sweden (intentified as Telenor Sverige)
I'm using a Ubitique EdgeRouter X v2.0.9-notfix.7 (latest firmware)
Roon core is installed at my Synology DS1821+ with DSM7, I tried to acess arc via Windows 11 computer.

Hi @Hampus_Martinsson,

Thank you for your post. The diagnostic snippet you’ve posted shows that UPnP, the pre-installed service your router uses to configure port forwarding for RoonServer, is not currently activated.

First off, if you have a second router in your setup provided by Telenor Sverige/Ownit Sweden, you’ll want to place that in Bridge Mode.

Secondly, you indicated in your post that you’d already activated UPnP, but RoonServer has failed to detect it. If this feature isn’t available on the Edgerouter X in your setup, an alternative is to manually configure port forwarding:

In the fields you’ve indicated above, try the following:
-Outbound Interface
specify address and/or port
-Src Address —> The IP ADDRESS listed in Roon Settings → ARC
-Src Port ** The PORT (55000) listed in Roon Settings → ARC

Use these same entries for the inbound and outbound sections. Make sure the protocol is set to TCP, not UDP.

If this doesn’t work and you still receive an error diagnostic snippet in Roon → ARC, then post it here in response.

An alternative to this process is to install a third-party workaround, called Tailscale. It’s a VPN that many ARC users have found successful:

1 Like