Troubleshooting Ropiee/RPi/IQAudio Digi AMP+

I need troubleshooting help. I still have issues getting my fourth (final) Ropieee kit up and running. IQAudio provided me with a new board, and I confirmed it was working with their test file. It played music to the attached speakers. I don’t know if any internet access occurred then.

Then I flashed the latest Ropieee, achieved steady flashing, but had no apparent connection to the internet and could not access the kit.

Troubleshooting steps since have included: reflashing; switching cables; switching switch ports; power cycling network; switching power supplies; switching SD cards; and rebooting everything.

On my router, I have tried accessing all the “unknown” net connections to see if they talk back. Also tried ropieee.local but “site can’t be reached.”

One other little useless clue: this RPi “saw” the network with my first audio card, and I had set it up with a static address. But I never got any sound so I got a new audio card.

Is there anything left to try, good people? I’m at the edge of my knowledge, to say nothing of my patience. :slight_smile: Thks in advance.

How did you do this?

I’d probably try the following:

  • Use an SD card from a working device;
  • Remove the DigiAMP+ and test the RPi alone;
  • Try the DigiAMP+ on another working RPi;
  • Check the network activity LEDs on the RPI;
  • Hook the RPi to a TV or monitor to see what’s happening during boot.


I flashed an image provided by IQAudio, which when booted (mounted on the RPi)
played a short audio file to the speakers. BUT, I don’t believe that their test involved internet access.

Did that.

Did that. As per setup instructions, the LED flashed fast during bootup and slowly thereafter. Compared to its working twin, the LEDs appeared entirely normal.

Yeah, looks like that’s next. Tried to avoid that

Well, the HAT is functioning, and it functions with the RPi in question.

I ordered another RPi. My time is worth that, I think. Keep you posted. Many thanks for the ideas.

Yes, I’d agree. :smile:

Do you change the hostnames for each of the working Ropieee images? I’ve given mine unique hostnames and also reserve an IP address in the router (still using DHCP.)

Good luck!

Martin, the new RPi for my AMP+ project showed yesterday, and today it still sits on my drawer, taunting me. It asks smugly, “What happens if I don’t work? Who or what will you blame then?”

I have no easy answers, only fear and trepidation. I have already ducked the build for as long as I can. Today’s the day. Fish or cut bait. Sound or no sound. Sound or the Fury…

OK, stopping silliness now. :slight_smile:

1 Like

Get a grip, you can do it! :smile: