Trying to get Roon ARC to work - port forwarding doesn't work (multipleNat etc problems etc) - now have lost all contact with Roon Core.... 😭

Roon Core Machine

Networking Gear & Setup Details

NUC Kit i7-10710U. Roons operating system.

Connected Audio Devices

Linn Akurate DSM with network cable connection. Also a bunch of smartphones, tablets etc.

Number of Tracks in Library


Description of Issue

Have tried to get Roon ARC to work without result. Auto config. of port forwarding does not work. Have - to the best of my ability - followed the instructions here: Latest error report inserted below. Have tried to set a fixed IP adress to the Roon core and as a consequence now lost all contact with the Roon core. (Have done hardware resets of routers, switches, NUC etc - no difference, does not solve problem.) I’m no network technician as you probably figured out. Please help, this is just too depressing…


“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 90.143.XXX.XXX:XXXXX, response code: undefined, body: undefined”},

“external_ip”: {“actual_external_ip”:“90.143.XXX.XXX”,“router_external_ip”:“”},

“status”: “status”: MultipleNatFound


“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}


At least, you have 2 routers in serie. You need to add a port-forwarding rule into the WAN siede connected router, which firwards port 55000 to the IP of you core. Make sure, the core is listening the exact same port Settings → Roon ARC → righthand diwnside of the page

1 Like

Thanks for your answer. Right now I can’t do anything since I can’t access the Roon OS Core - right now I would be happy just to use Roon as I have done before. If I manage to access the Roon OS Core again, I guess I can try to follow your suggested set of actions. Not possible right now though. How can I reset the IP number of the Roon Core when I don’t know how to access it?

I found a diagnostics page in the webinterface of my broadband modem/router. Tried to ping the fixed IP adress that I tried to set directly in the webinterface of the Roon OS Core. Result: “3 packets transmitted, 0 packets received, 100% packet loss”. This does not seem promising…

OK, then you need to do a network reset of your ROCK/NUC first. See:

1 Like

Thank you so much Geoff! I will try that!

Worked well, thanks Geoff! I will now investigate what Stefan suggested above!


Problem solved! Entered ip adress and port number in the routers webb interface for port forwarding. Thanks Stefan and Geoff! :blush:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.