Trying to get Roon on a Mac to talk to my PSAudio Directstream

When I try to play music I get a message “Playback has failed due to playback parameter negotiation with the audio device”. Is this a problem the settings I have put into Roon, or an issue with the System/Sound settings on my Mac?

Hey @Rory_Flynngive this a read, and let us know how you have things set up. I’m sure we can figure this out, lots of people using the Directstream with Roon.

This might also be worth a read. Thanks!

System: Mac OS X 10.11.1
File I’m playing: Apple Lossless, 16 bit, 44.1khz, stereo, “m4a” extension
DAC: PSAudio, 1.2.3
3rd party software: I don’t believe so

Ok, progress of sorts. I upgraded the Directstream to 1.6.4, and now I don’t get that error message, but I do get silence.
I have to confess I did have Bitperfect installed earlier on (had forgotten about it). I have deleted it from the machine and restarted the machine after the delete.

Ok, we’re getting there :smile:

Sorry to ask the obvious, but can you confirm you have volume up in Roon, and that you have the DirectStream set to the right input? The source selection could be the issue here.

The Directstream is on “USB”, there is a USB cable connecting the 2, the Roon software has a 73 under the speaker icon, disable volume control is not ticked.

An odd thing, when I do press play the graphic at the bottom that shows the track sound profile and length shows the red progress bar, and the bar isn’t moving.

I’m running Roon (trial) to a Directstream (Yale Final) with no issues. I’m hoping I can help.

I can’t see your options that are underneath the Output Settings dialogue above. I trust that you’ve selected the PS Audio USB 2.0 as your output? I’ve also selected Use Integer Mode if supported – I don’t know if it is – and Roon reports that I’m now running bit perfect.

The Directstream is also known to sometimes be finicky about changes. Have you restarted the DS after changes? It sometimes helps.


I’ve, PSAUdio selected, Integer mode, restarted the DS. I see that other people get things happening without any drama, so I’m either missing something blindingly obvious, or… something.
One possibility, I know that I made some change in Audio MIDI Setup some time in the past, any suggestion on whether they could be relevant?


Absolutely Audio MIDI could be getting in the way, and that’s a good thing to have noticed. I seem to recall some issues around Audio MIDI on the PSAudio forum.

Here are the settings I have on the Mac Mini.

Your Output settings above appear to be as I have them, except for Max DSD Sample Rate (DoP). Mine is set to “disabled” and I was able to play several DSD albums, including 128, with no issues.

Now, I hate to have this seem obvious, but are you certain that you’ve chosen the correct USB input channel on the DS?

It might be interesting to know: Can you set Roon aside for a moment and play music through the DS as you had been doing? (I’m assuming you had been playing the DS at some point.) If you can play iTunes with or without PureMusic, Amarra, etc., then at least you know your signal path from the computer to the DAC is legit, and that narrows the issue to Roon.


Starting at the end, JRiver used to work, but is not now. And I can’t get iTunes to output through USB. So it is a more basic problem. iTunes behaves as if it is playing, but no sound emerges, JRiver just sits there.
I’ll get back to you, this isn’t a Roon problem.

Update after a bit of experimentation
Rob, you are a smart guy. I have 2 DACs, 2 USB cables, & 2 Macs. I tried the other DAC & another cable with the “Roon” Mac and that worked fine. I tried the DS with the original cable with another Mac and that worked fine. Then I went back to the DS, original cable, Mac with Roon & zilch :confused: What would you suggest?

I’m using Roon with Directstream on Mac and I get the same error message too on occasion. I simply unplug and replug the usb cable on the Mac end to fix it. Annoying but the fix works for me.

Andy, I cannot get the Mac+Roon to talk to the DS, at all. Not even once. The DS appears in System Preferences/Sound, and also in System Information as a USB device, but I havnt gotten sound out.


Hmmm, interesting issue. I think I need another cup of coffee.

The first alternative setup (‘other’ DAC & cable + Roon Mac) suggests that Mac and Roon are functioning correctly.

The second alternative setup (DS, original cable, other Mac) suggests that DS and original cable are functioning correctly.

So, if DS, original cable, and Roon Mac all work in different configurations… all components function, just not in the configuration that you’d like to see. Sheesh.

All I can suggest is that you try to knock out each possibility one-by-one. Perhaps try DS + Roon Mac + different USB cable. If still no joy, swap the DS out for the other DAC. Then, swap Macs. I think that’s the only way to isolate the problem even further than you already have.

All these green R’s are confusing – one of you two needs an avatar :wink:

Anyway, we’ve heard reports that occasionally the DirectStream needs a hard reboot, particularly when moving between different computers. If you’re troubleshooting, I would definitely recommend that, in order to keep your tests clean.

@Rory_Flynn – I’m reading this back, and I want to make sure I understand the current symptoms.

So, the DS shows up in Roon, you have it set to exclusive mode, you have chosen the correct output in Roon (lower-right, next to volume), and when you hit play, what happens?

The track loads? Does time tick up? Any error messages? What happens if you play via the System Output?

Roon_on_MacMini - Blue Heaven USB - DS
Exclusive mode + USB (on DS).
What happens? Lots of fiddly stuff. In iTunes: the program behaves as if it is playing, but no sound comes out. In Roon: the play progress bar sits at zero. But when I look in Zones the chosen track is shown as playing. Overall the setup is sluggish (lots of pauses, “not responding”)

Just to add to the mix…I am currently listening happily to:
Roon_on_MacMini - Blue Heaven USB - Bel Canto DAC
iTunes and Roon both just do it.

And I’ve connected the DS - Blue Heaven USB - MacBook
Quicktime plays an Apple lossless track without any issue. So it isn’t some combination of cable & bandwidth.

The only difference I can identify is that on the MacBook Audio Midi Setup shows the PSAudio Format as 48000 2 ch - 16bit, where the MacMini insists on setting it to 44000 2ch - 24 bit. Any attempt to change anything in Midi Setup triggers the “rainbow roundel” and system pauses.
Interesting that the Bel Canto seems to get 44000 2ch 16 bit easily in Midi Setup.

Everything is working fine. I reset MIDI settings, but also started using a shorter USB cable. Not sure what did the trick, but my listening room is now a mess.

1 Like