Trying to install and setup roonserver remotely (using roon on desktop)[Solved]

Well, I can tell you that I am pretty good at computer audio…yet I am wayyyyyy over my head here with this awful Roonserver setup. I am forced to do roonserver cuz my targeted platform is a WS2012 R1 GUI with AO and Roon does not run on it (OpenGL 3.0 issues). So I am doing Roonserver, with trying to do Roon remote on my home office desktop for now (cuz my iPad 3’s are all too old for Roon!!). My home office desktop was host to the previosu Roon complete install. My goal, as a charter HQPlayer user, is to use Roon as a front end to HQPlayer and my NAA.

I installed roonserver on my CapsZuma sitting next door in my music room (known as Caps-Core on my net). Then I uninstalled my perfectly good Roon install on my desktop (cuz I only own one license) and re-installed Roon. This time I told it I wanted to use it as a remote only and it told me I had to deathorize my desktop first. I did. It easily found that roonserver was running on Caps-Core (currently no setup, no music library set, nothing, cuz roonserver has no GUI of course). However, for a music library (currently a temporary 2TB USB drive locally connected to Caps-Core cuz I am having Synology issues) it is asking me for all kinds of path names, passwords, etc. No frickin idea at first, but I have been learning some things over the past four hours or so!

Wild that it instantly found Caps-Core roonserver, calls it CAPS-CORE, and yet won’t offer me a hint of what the path name to my USB drive should be. I am also confused as to whether it’s other watched drive names (like c:users/admin/music) is my desktop C drive or the CAPS Core c drive, cuz, for example, the audio path called “this pc” is indeed my desktop (where I want nothing to happen except Roon remote). Very unintuitive. I’ve tried every combination in the known universe, and even set the drive for full sharing (which seems silly cuz I am not going over a network, only the Roon remote is) It says “connected, watching for new files” but does nothing, even with a forced rescan.

It’s as though Roon, being told it’s only a remote, and that roonserver is on CAPS-CORE, still wants to assume all the libraries are on my desktop. Help!!

In the Storage tab of Settings of Roon on a remote, paths to connected storage devices / folders are local to the core/server machine, not to the remote.

In your case, it’s most probably D:\ (or whatever letter the USB drive on your server is mapped by Windows), likewise D:\foldername.

Hey @Ted_Brady – let me know if you’re still having issues here, or if you figured this out.

If you’re setting up RoonServer, you can setup either:

  • A network drive (meaning a NAS, or a shared folder on a computer other than the computer running RoonServer)
  • A local folder, meaning a drive connected directly to the computer running RoonServer

If you’re trying to set up the latter, you need to click Add Local Folder, as shown in the lower left below:

Once you’ve clicked Add Local Folder, you’ll get a popup explaining that you need to enter the path of the local drive or folder:

As @RBM mentioned, this will be something like D:\.

We’ve had a few people confused by this process, so I’m going to look into whether there are changes we can implement to make this more straightforward. Building a cross-platform file browser that would allow you to browse the Core computer remotely isn’t a simple project, unfortunately.

Yes, thanks… I did that numerous times (as it’s about all one can do, right?) cuz every time it would scan for a few seconds and then say 1293 files and then give the “watching” message and NOTHING would happen. I am still at Zero albums or tracks (my previous “normal” install had 40k albums and 8TB of redbook and hirez/DSD…so I am used to Roon seeing music). This 2TB USB is just a small subset of DSD, 24 bit and redbook…all well tagged (I am tagging expert at NativeDSD).

Hmm, ok. So you’ve got the folder added, but nothing is importing?

Are you still seeing the spinner in the top-right near Search and Bookmarks?

No, no spinner ever. And the “scanning” message was fleeting. I’ve tried to remove and add E:\Stereo stuff (there’s multichannel on the drive, too so I just want that folder) a couple times, removed and added the full “E:”, doesn;t matter…and have never got the “scanning” message again. I’ve even added some music to the drive (I can RDC into the CAPS-CORE and drag some music from my NAS over to the USB drive) and nothing from Roon says it scanned, updated or anything. Simply shows “watching for new music” message. But albums/tracks/etc still show as Zero, and this after five hours of doing this.

I assume if it didn;t see this folder it would say so, right? I may try to add F:\ (which doesn’t exist) and see what it says. Update: in red says drive is not available…so that is a good thing. It makes me feel like it sees E drive at least.

Ok, let’s get some logs and see what’s happening here. It’s possible our scanning is stuck on a non-standard file tag, corrupt file, or something like that.

I’ll follow up via PM Ted – stand by!

Hey @Ted_Brady – Sorry, I must’ve missed in your original post that you are running Windows Server 2012 :frowning:

While we don’t officially support Server 2012, most people who want to run it have been able get it running. That said, you will need to install Microsoft’s Media Pack in order to use Roon.

Can you give that a shot and let me know if things are looking better? Thanks!

That link is for R2. I run R1. I am close to giving up.

BTW, my Roonserver on that WS2012 R1 shows no signs of a bad install (task bar icon says it is running). The issue is raised once the remote GUI can’t catalog anything.

I am contemplating going to Windows 10.

Hey @Ted_Brady – sorry for the slow response. Based on what we’re seeing in the logs, this doesn’t appear to be a bad install – it just looks like the standard codecs that Windows ships with are missing, so we’re not able to decode or import your files.

Since Windows Server doesn’t ship with these codecs, we don’t officially support it. That’s why you’ll need to add the Windows Media Pack in order for the import to proceed successfully. I’m not familiar with the distinction between R1 and R2, but I would start with there. Just let us know if you’re still stuck.


Update: Installed R2 on another partition of my i7 server, ran Essentials (without config wizard), rebooted several times, and then Media Pack, installed Roonserver…and voila! Roon remote (my desktop for now; Surface 3 or iPad after I get back from CES) is finding my local USB hdd music. Thanks for the help and patience.

I will tackle HQP integration (long time HQP user) as soon as I get back. I will comment on that in the appropriate thread(s).

1 Like

Great news @Ted_Brady! :tada: Happy New Year!