Trying to install codecs on new ROCK install but having network issues

I don’t know about most of you but installing Roon Rock has been a super pain in the arse… It is on a NUC717DNB.

I do have music playing finally. But I still need to install codecs.

When I try to access ROCK in my Windows 10 PC Network section in File Explorer I see ROCK in the computer section. But if I click on it I get a message Windows can not acces \ROCK.

I have tried to Map Network Drive but I am getting a message about not having access because of your organizations security policies. I have given all the access I know how to in network sharing.

Here is what I am looking at. Any help would be greatly appreciated!

google adding SMB V1 to windows

Thanks, I should have mentioned that I have already done that in Windows Features.

OK then the clue is in the windows box message about guest shares…you need to google how to resolve that. I hate windows for these kinds of issue.

If you are on a work/company machine then you better seek advise from your IT folks about changing these settings as it could impact on your internal security policies…just saying.

Thank you! I found this page and it fixed it immediately.

No it’s just my main 2 channel system. Codecs applied and all is good! :yum:

1 Like

Well,if he was using Windows as the RoonServer OS, he would not be having all these issues. :wink:

I run a core on windows 10 so I’m well aware…doesn’t mean I like it, but also supports some other apps from time to time that won’t run on other platforms and some devices with driver requirements to get their maximum specs like DSD native support. I also have to support clients with windows installations (maybe more reasons to dislike it :rofl:) but I will say windows 10 is a big improvement over past releases…all os’s have their issues I still find I have to go thru more hoops on windows than I do with macOS/OS X…I’m not a big Linux fan or guru either but my Linux web server (data center hosted) has been running for close to 900 days without a reboot. And it’s kept updated weekly.:nerd_face:

I had this issue as well, the solution is this registry key;


Change the value of AllowInsecureGuestAuth from 0 to 1.

Its the kind of setting that a work computer will have configured via group policy as it is quite insecure. My advice would be to change the key back to 0 again when you are done.

EDIT: Just for completeness I should describe what it does. This setting allows (or denies) the use of a network share when no password is required to connect. Guest authentication.

EDIT2: Just realised you already found the solution. So, as you were :flushed: