Trying to update Ropieee results in a loop

I went to ropieee.local and it said.

“There is an update available for your device!”

Then I followed the instruction to download/update but it got stuck at updating/rebooting.

Did I do something wrong? I waited about 15 minutes and decided to flash a new install.

I have the same problem. Stille updating after 1,5 hout. Anyone?

No one else? Perhaps it only affects Peter H.'s. :slight_smile:

After a fresh install of Ropieee, Roon Bridge Version 1.7 (build 571) got loaded. Now, it is again asking me to update. This time I am not falling for it.

1 Like

I’ve been sitting on an update to RoPieee for 3+ hours. Will probably just do a fresh image.

I have tried to update Ropieee on two separate endpoints today. I have tried a total of 3 (or 4, I lost count) separate SD cards, both brand new and reformatted old cards. I lost count of the number of re-flashings of the image - I think about 5. I also tried two separate images.

Still nothing. It got perpetually stuck on rebooting each time, giving me the increasingly infuriating ‘the page will be available again in about one minute’ message.

I am officially exhausted and have given up. I then tried to run Volumio on both endpoints using the exact same setup. They both worked flawlessly within minutes. So please don’t tell me it’s a network cable, or some such.

Really trying to find a compelling reason to renew my annual subscription at this point…

Your annual subscription is not with me, but with Roon.
You do realise RoPieee is a spare-time project?

Sorry you feel this way. If you reached out earlier I could have tried to help you.

Yes, apologies - I do realise this. That comment was reflecting that I am also less than enamoured of 1.8 sadly. You do an amazing job with Ropieee and thanks for how much you have enhanced the Roon experience for me through it. Just seems since 1.8, the ripple effects are irritating.

1.7 works fine on RoPieee. I am not going to update for now. :slight_smile:

RoPieee is rock solid. On the other hand, this 1.8 rollout is a nightmare. Perhaps Roon should learn from Tesla.

There is no good alternatives to Roon though. I am sure it will settle down. I will continue my monthly subscription.

There was no update of RoPieee or RoPieeeXL associated with the update of Roon from 1.7 to 1.8. If your RoPieee device was current, you needed to do nothing with it.

I had the same issue with my Ropieee raspies. They wouldn’t update when network connection is on external USB Wifi (I use a tp-link dongle based on a Realtek chip). The upgrade was discoverd and downloaded but after reboot the network connection never came back. In that end I had to connect the Rpi to Ethernet with out the Wifi dongle attached, perform the upgrade and afterwards attach the dongle again and configure it. Then I could reboot it and access via Wifi again. It would of course be nicer if I just could upgrade the Ropieee devices without having to fetch and connect them to Ethernet first in order to upgrade Ropieee. But at least I know how to circumvent this problem.

Maybe this helps others, too.



I will wait a little bit and see if a better solution becomes available.

I don’t have an Ethernet switch and I have to borrow the connection from my NAS/RoonCore every time I need to use Ethernet on the Pi.

Same here. But after that update last 30mins, I lost my connection with HQPlayer.

any updates on this? I went to install the newest version of Ropieee to see if it helped improved my 1.8 experience, but I can’t get the web UI to load after clicking download/install/reboot

unplugging the Pi and plugging it back in worked