Twitter Integration Broken? [resolved]

This was working, now it’s not. Went to post and Roon reported that I was not connected to Twitter (I was the other day) Running through the ‘Connect to Twitter’ routine, entering code etc loops back to ‘Connect to Twitter’. Tried revoking access and re-adding Roon, logging out and back into Twitter, rinsed and repeated but no change.

Any other reports @support ?

Hi @Wakajazz ---- Thank you for sharing you feedback with us. We just gave this a shot here on our end and we were able to post a tweet successfully. Have you tried power cycling your equipment yet?


Hi @Eric, thanks for reaching out. Yes, all appropriate devices bounced: 3 x RPi RAAT’s, 2 x Roon Controls (OS X), 3 x iOS Remotes and the Roon Server (Windows 10). Still in the ‘Connect to Twitter’ loop. Everything else working just fine.


Can you send us a set of logs @Wakajazz? Instructions are here.


@mike , Link to logs sent.

@mike I checked Roon today and my Twitter account is showing as authorized again… I did nothing since the reboots and log submission Friday. I wonder if this was a Twitter issue?

UPDATE: Showing as disconnected again this morning… unable to reconnect.

Hi @Wakajazz — Thank you for the follow up and my apologies for the continued troubles.

I wanted to touch base to confirm that we’ve received your logs and that they are currently in our queue to be evaluated. We’ll have a look and let you know what we come up with. Your patience is greatly appreciated!


Hi @Wakajazz ---- Thank you for your patience while our tech team has been looking into this behavior for you. As per their request may I kindly ask you please try the following:

  • Go to twitter > Profile Settings > Apps > ‘Revoke the access’ for Roon app
  • Restart the machine where Roon is runnig
  • Launch Roon
  • Try once more


Hi Eric, Roon is currently connected to Twitter and has been since the last Roon update. If the issue resurfaces I’ll get back to you.

1 Like