Twitter Integration Broken


After Updating both core and iPhone application the integration with twitter is broken.

He keeps asking to connect , I a do authorise it , but it doesn’t work, it doesn’t connect.

I mean on both application is the same. Did you test it?

Following another post I did de-authorize the application on twitter and i did restart both device but same issue on both. ;-(

I know it’s not the main feature however …

Core 223
iPhone 1.3.00223
Mac Os Sierra 10.12.4

Iphone even worst now as soon as you try to insert the authorisation code the page closes itself it’s so irritating,

This functionality is completely broken both on core and iPhone

It’s the same as
This was working, now it’s not. Went to post and Roon reported that I was not connected to Twitter (I was the other day) Running through the ‘Connect to Twitter’ routine, entering code etc loops back to ‘Connect to Twitter’. Tried revoking access and re-adding Roon, logging out and back into Twitter, rinsed and repeated but no change.

I did power cycle everything but it simply doesn’t work

On iPhone the page reset itself even before placing the authorisation code.

It is a server or app issue? I have tried everything, restart, reinstall…

Nobody around?

I have all the same stuff (iOS v10.3.1). I just tried on my iPhone 6s and shared the currently playing album to Twitter with no problems.

Tagging @support.

Hi David, thank your your reply, so it looks like an app issue…

However I did try everything

Of course, and I just tried again here as well – no issues for me. Would you mind quickly creating a new profile in Roon and trying again?

If that doesn’t work, can you dump me a set of logs from your Core @Guido? You can find instructions here.

Thanks and sorry for the trouble!

Hi Mike,

Thank you for your support I don’t have dropbox and I am not going to have it i don’t trust them sorry.

You make life a bit difficult since i cannot even upload a pdf or equivalent to show you the situation…

In the instruction provided it is mentioned that you can provide a temporary access… or something similar to upload the document

I did create a new profile guido tmp, but the issue is the same.

Got the logs ready for you

This what I did

Roon on Twitter

  1. Revoke

  2. Mac Restart = Roon Gone from twitter

  3. Trying again

  4. Share

Place the pin and…

Back to Square one,

I did the same with a profile just created … same result

Sorry for been a bit grumpy I have the final MSc exams next week…

This is still a great application




Hi Mike,

I did reinstall the application on the iPhone , now he does allow me to insert the twitter pin code but then goes back to the beginning asking to connect to twitter, I think i have exhausted my idea now…


No problem, I just sent you a message with instructions for sending us the logs directly. Sorry again for the trouble, and good luck with your exams!

Hi Mike,

Today is working again , I did cancel the trial on my temporary profile so hopefully I won’t be charged, so at the end maybe it was a temporary problem on your side?

Regards and many thanks for your support

Hi @Guido ----- Thank you for touching base with us, glad to hear things are working as needed now.

Apologies for any confusion on my part, but can you clarify what you mean by “my temporary profile”? Are you referencing your account created on the Roon website with a credit card OR your in app profile?


I did crete a temporary new account on roon to check if it was a profile issue as suggested, It works on the iPhone as well