Two airplay speakers, work fine individually but nothing output when grouped

Have been using Roon for a few months now and has been great for my main hi-fi, but today I wanted to set up a grouped zone output and am coming across an issue. I have 5 or 6 different endpoints setup but only two of them have Roon installed (one for the core, one using Roonbridge on DietPi) and the rest are using Airplay.

I tried to set up a grouped zone of 4 different airplay speakers but when trying to play anything I get no output, although the playback bar does seem to take 1 or 2 seconds to start the roon player is showing that its playing although nothing is output on any of the speakers.

After that I tried using just a group of two speakers but even that wasn’t working - again, Roon seems to show that its playing but most of the time it only plays on one device (seems to do this when playing to one airplay endpoint before adding in a second - although nothing plays on the second) or none at all.

Endpoints set up are -

Office PC (Roon Core & Airplay receiver)
HiFi RPi (Roonbridge & Airplay receiver)
Airstream (Airplay only)
B&O active speaker connected via Airport Express (Airplay only)
Yamaha Receiver (Airplay only)

Just wondering how I can actually troubleshoot this as Roon doesn’t seem to give any errors?

Hello @jackb,

Have you tried different combinations of devices when you’ve done grouping with only two devices? This will be important to establish in order to troubleshoot this issue. We have many users using grouped airplay functionality successfully, so I’m curious if this is just a misbehaving device that’s taking the whole group down with it or if there may be a configuration issue somewhere that would effect grouped playback.


Hi @john,

I did end up trying different groupings and the results were hit and miss (mostly the latter), but have just retried a few this morning and got -

HiFi RPi & Airstream = if one device is already playing then it will continue to play once grouped, but the second device won’t start at all. I have confirmed this happens either way (RPi first with Airstream grouped in, and Airstream first with RPi grouped in - both have the same results)

Whats more interesting though is that after the failed grouping, the second end-point starts to show some weird behaviour.
With the first attempt where the RPi continues playback and the Airstream fails, even after ungrouping the Airstream becomes unfunctional until something is reset, I ended up having to open the Roon device settings and making a change (and subsequently changing it back) before I could restart playback on the device.

This pretty much happens the other way around too - when successfully playing to the Airstream and adding in the RPi it seems only the Airstream continues to function. However after ungrouping it seems you can no longer airplay to the RPi, instead I have to play something over Roonbridge which seems to reset it so airplay can work again.

I understand that many people are using the grouping without issue but just wondering how I would even go about troubleshooting this - are there any log files I should be looking at?
Happy to do more tests though, this was one of the attractive functions of Roon that influenced the purchase so would be nice to have it working.


Hi @john - just did a little more testing, this time pairing the Airstream with the B&O Airport Express speaker and had very similar results.

If the Airstream is already playing then when adding the Airport Express endpoint then the Airstream will continue to function but nothing is output of the B&O speaker. After ungrouping I continued playback on the Airstream without issue but am finding it impossible to get the B&O speaker to output anything from Roon. I have tried the device settings update but that didn’t seem to reset things either. However, while Roon is unable to output to the Airport Express B&O speaker if I use standard airplay from my iPhone then this works fine, suggesting the issue is somewhere in the Roon system.

Hello @jackb,

After speaking with the tech team regarding your issue, they’ve requested that we enable diagnostic logging on your account. The next time you encounter this behavior, please share with us the time of day (local) that it occurred. When I receive your report, I will then be able to request a diagnostics package in that time frame to be passed on to the team to take a look at.


Hi @john - thanks for getting back to me, have been on holiday but just tested it out this afternoon and wanted to send some details so you can debug.

13:26 - restarted Roon core to start afresh. Played a few tracks to the HiFi RPi (roonbridge) without issue
13:30 - played some tracks to HiFi RPi via Airplay (through Roon) without issue
13:31 - created group with Airstream and HiFi RPi, only the HiFi RPi output anything and that was after a delay of maybe ~20 seconds after creating the group
13:33 - Ungrouped Airstream and HiFi RPi, HiFi RPi continued to work over Airplay, switched to Airstream only and no output
13:36 - Started Airstream via the iPhone playing over Airplay and that worked fine
13:37 - Started playing to Airstream via Roon and that worked fine
13:38 - Created group with Airstream and HiFi RPi but only the Airstream continued to play (that didn’t have the ~20 second delay though)

Hope thats enough information to start with but if you or the tech team need anything else then let me know as happy to assist

Hi @john - just wanted to check to see whether it had been passed on to the technical team?

Hello @jackb,

I’m sorry for the lengthy wait on our end of things, we are still looking into this issue. It would help if you could clarify if by “Airstream” you are referring to the software package or the speaker from Monitor Audio named “Airstream”.


Hi @john, thats understandable, just wanted to make sure it hadn’t been forgotten about. And yes for this the Airstream is the speaker from Monitor Audio (specifically the s300) - I have other endpoints setup though and can try replicate it on other speakers if need be, just let me know.

Hi @john - just wondering if there has been any update on this? Would love to have this working for the summer

Hello @jackb,

We have been trying to get our hands on a Monitor Audio S300 so that we could reproduce this issue in house, but unfortunately since the product is discontinued we have been unable to do so. We have performed extensive grouped airplay testing and have not seen this issue occur with other devices.

While suggesting purchasing extra hardware is always our last resort, a potential option for you to be able to get this speaker working in your system could be utilizing another Raspberry Pi and using the Aux input on the Monitor Audio speaker.