Two issues: can't play through HQP and Roon 'hiccups"

okay so earlier this week I had issues with playing through HQP. Last night I got HQP working and it sounded decent but had a few hiccups here and there.
After my listening session last night I turned everything off. This evening I turned everything back on and HQ Player would not produce sound but Roon works. Roon sound quality is bad, lots of skips/hiccups…
ideas? help?

Note for @support , previous thread is here.. Brian is using a Windows 10 PC directly connected by USB to a Lampizator 7L.

Brian what CPU do you have in your PC ? Has Roon completed it’s analysis of your files ? You can tell this by whether there is a little spinner in the top right of the UI showing analysis progress when moused over.

This KB article may be of some assistance.

Hello, I had issues with HQPlayer working with Roon. I thought I had this solved, in fact, last night I was listening through HQP.

Last night I shut everything down and tonight when I turned it all back on I can’t play through HQP. I can listen through Roon though…

What the?.

Hi Brian

I don’t think it’s useful to open a new thread for every facet of your HQP Lampi issues.
Stick with one thread and we (the community and the very helpful people from roon) will certainly find solutions.

Christoph (also Lampi owner and HQP-roon user)

Hi Brian,

I’ve merged both current threads so they can be dealt with at once.

When diagnosing issues with HQP I would suggest the following checklist:

  • Is the DAC powered on and USB input selected ? (USB inputs cannot be detected by Roon or HQP unless selected on a powered up DAC)

  • Is the HQP Zone selected in Roon ?

  • Is the appropriate Backend and Device selected in HQP ? This may have reverted to a default.

  • Is the appropriate rate and output selected in HQP ? Sending PCM to a DSD only DAC or an unsupported resolution will result in silence.

  • Look at the HQP screen after pressing Play in Roon. Do you see a blue bar filling right and left ? This indicates HQP is receiving a signal but is either initialising or doesn’t know where to send it. If upsampling to DSD 512 some filters can take a long time to initialise. Your CPU will be working hard if this is occurring.

  • Do you hear music if you select the same rate and output as the input and “none” for Filter/Dither or Oversampling/Modulator ? If so then there is an issue with the filter modulator selection. Try a lower resolution and see what happens.

  • Some filters do not support non-integer Output resolutions. Check the Auto rate family box and see if that makes a difference.


Hi Andy,

I can get HQP to play with Roon but it takes a few tries at least. What I mean by that is, if I turn off the system (CPU, Lampizator) after a listening session I have issues when I turn everything back on.
Roon will show the Lampi as the output but with no action on the ‘blue bar’.

What I have done then is gone into HQP and checked the settings and they are correct. I then restart everything and it works. It takes three or four tries sometimes but HQP/Roon always work.

Any idea what this could be?

HQP can be sensitive to the order in which things are shutdown or started. When you shutdown I’d suggest closing HQP, shutting down the CPU then turning off your DAC. Reverse that order to startup, DAC on first, then computer/HQP.

The idea is not to let HQP “see” the DAC disappear from or appear in the system.

Try that out and let’s see if it helps.