Two PS Audio DirectStream DAC's w/Bridge, One Works One Doesn't

So I have a weird one… I work at a PS Audio dealer. We have both the DirectStream and the DirectStream Jr. Now here is the weird part… The DirectStream Jr. works flawlessly its awesome, but the DirectStream wont work at all! I spoke to PS and they said that both units basically use the same network bridge. So Im not sure whats going on. Any suggestions?

Hi Paul,

Did you get this sorted? I assume you power cycled both units. Have you quit Roon (or Roon Server) and restarted?

If you don’t have any luck, we will flag the Roon guys for help.

Cheers, Greg

Unfortunately this still has not been sorted out. I tried restarting the roon server but still no change. I have verified that the network connection is good I can ping the unit so I know it’s online I can even stream Jrivers so I know the network bridge is good

Hi Paul,

Let’s get @eric to take a look and see if he can help.

I created a new thread for this issue.

Cheers, Greg

@Paul_Becerril – can you give us some of the details listed here?

We’re particularly interested in the details of your setup, the various DS version numbers, and whether you’ve rebooted the DS yet :grin:


Yes I rebooted the DS a couple of times… I also checked with PS to make sure I was running the proper firmware for both the DS and its network bridge. As I mentioned before we also have a DS Jr. That is running the same bridge firmware (I should also add that PD stated that both the DS and DS Jr. are using the same network bridge) I even switched locations of both units and the result was the same… Jr. Worked flawlessly and the DS still wouldn’t connect


I have similar problem. I have discussed with PS audio already and checked that I have latest firmwares on DS and network bridge2. I also have latest Roon. Since I have struggled with this already two weeks I think I have tried everything I can. I have rebooted DS, my Inteno router and macbook pro, which runs roon, several times. I have also tried to turn off firewall on mac and router. Nothing works. Roon just can’t find the DS with bridge. Currently I use minimserver(on NAS) and Mconnect and this combo works flawlessly so I think DS is working like it should and can be found from my LAN. Otherwise Roon seems to work. It can find my files from NAS and also can be seen by remote (iPad).

What are the DS version and the Bridge II version?