Ubuntu updated/upgraded to 22.04, devices cannot connect anymore

Yesterday I updated some packages on my Roon Server (Ubuntu 20.04). Today I recognized that no device (iOS client on iPad, iPhone, Roon.app on Macbook) can be connected to my Roon Server.
I uninstalled / reinstalled the Roon Server (via roonserver-installer-linuxx64.sh) but the Core cannot be found. I upgraded to Ubuntu 22.04 and uninstalled / reinstalled the Roon Server but the Core cannot be found.
The server has an ip address and I an ssh to it.
There are some warnings in the Roon Server Logs like

01/26 22:48:46 Warn: [multicastreceiver] couldn't bind to iface, message: Invalid argument
01/26 22:48:46 Warn: [multicastreceiver] couldn't bind to iface, message: Invalid argument

The Roon Server worked fine til yesterday and nothing else was changed in the network.

Any ideas?

Best regards

Which ones? Check /var/log/apt/history.log, /var/log/apt/term.log, and/or /var/log/dpkg.log

Is the network on that machine working otherwise? Are the two interfaces up? Can telnet connect to and ?

(Not sure if these messages are necessarily critical. “Warn” level in logs is commonly not fatal in most software, and the entries occurred in logs here where they didn’t seem to be causing an issue: Nucleus Plus missing Codecs)

Which ones? Check /var/log/apt/history.log, /var/log/apt/term.log, and/or /var/log/dpkg.log

I did apt-get update and apt-get upgrade first, later I upgraded to 22.04 with do-release-upgrade.
The upgrades on 20.04 installed several packages (quite long list, see end of this post)

Is the network on that machine working otherwise? Are the two interfaces up? Can telnet connect to and ?

network is working fine. ss -l does not contain 5350, telnet 5350 cannot connect.

Do you know other Roon related log files I should check for errors other than /var/roon/RoonServer/Logs?

List of packages installed during upgrade

Start-Date: 2023-01-25  17:55:22
Commandline: aptdaemon role='role-commit-packages' sender=':1.931'
Upgrade: libqmi-proxy:amd64 (1.28.6-1~20.04.1, 1.30.4-1~ubuntu20.04.1), tracker-extract:amd64 (2.3.3-2, 2.3.3-2ubuntu0.20.04.1), netplan.io:amd64 (0.104-0ubuntu2~20.04.1, 0.104-0ubuntu2~20.04.2), language-pack-gnome-en:amd64 (1:20.04+20220211, 1:20.04+20220818), xserver-xorg-video-amdgpu:amd64 (19.1.0-1, 19.1.0-1ubuntu0.1), gir1.2-notify-0.7:amd64 (0.7.9-1ubuntu2, 0.7.9-1ubuntu3.20.04.2), libnotify-bin:amd64 (0.7.9-1ubuntu2, 0.7.9-1ubuntu3.20.04.2), update-notifier-common:amd64 (,, libfprint-2-2:amd64 (1:1.90.2+tod1-0ubuntu1~20.04.7, 1:1.90.2+tod1-0ubuntu1~20.04.10), libsystemd0:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu3.19), apt:amd64 (2.0.8, 2.0.9), libkmod2:amd64 (27-1ubuntu2, 27-1ubuntu2.1), ubuntu-advantage-tools:amd64 (27.8~20.04.1, 27.12~20.04.1),
 libqmi-glib5:amd64 (1.28.6-1~20.04.1, 1.30.4-1~ubuntu20.04.1), python-apt-common:amd64 (2.0.0ubuntu0.20.04.7, 2.0.1), udev:amd64 (
245.4-4ubuntu3.17, 245.4-4ubuntu3.19), language-pack-en:amd64 (1:20.04+20220211, 1:20.04+20220818), libapt-pkg6.0:amd64 (2.0.8, 2.0
.9), kmod:amd64 (27-1ubuntu2, 27-1ubuntu2.1), libudev1:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu3.19), tracker-miner-fs:amd64 (2.3.3-
2, 2.3.3-2ubuntu0.20.04.1), libfprint-2-tod1:amd64 (1:1.90.2+tod1-0ubuntu1~20.04.7, 1:1.90.2+tod1-0ubuntu1~20.04.10), systemd-times
yncd:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu3.19), xdg-desktop-portal-gtk:amd64 (1.6.0-1build1, 1.6.0-1ubuntu1), python3-distupgrad
e:amd64 (1:20.04.38, 1:20.04.39), ubuntu-release-upgrader-core:amd64 (1:20.04.38, 1:20.04.39), language-pack-gnome-en-base:amd64 (1
:20.04+20220211, 1:20.04+20220818), systemd-sysv:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu3.19), libkeyutils1:amd64 (1.6-6ubuntu1, 1.
6-6ubuntu1.1), libmm-glib0:amd64 (1.16.6-2~20.04.1, 1.18.6-1~ubuntu20.04.1), libpam-systemd:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu
3.19), systemd:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu3.19), libmbim-proxy:amd64 (1.24.8-1~20.04, 1.26.2-1~ubuntu20.04.1), apt-util
s:amd64 (2.0.8, 2.0.9), libnss-systemd:amd64 (245.4-4ubuntu3.17, 245.4-4ubuntu3.19), libnetplan0:amd64 (0.104-0ubuntu2~20.04.1, 0.1
04-0ubuntu2~20.04.2), libtss2-esys0:amd64 (2.3.2-1, 2.3.2-1ubuntu0.20.04.1), language-pack-en-base:amd64 (1:20.04+20220211, 1:20.04
+20220818), ubuntu-release-upgrader-gtk:amd64 (1:20.04.38, 1:20.04.39), unattended-upgrades:amd64 (2.3ubuntu0.1, 2.3ubuntu0.3), mod
emmanager:amd64 (1.16.6-2~20.04.1, 1.18.6-1~ubuntu20.04.1), linux-firmware:amd64 (1.187.30, 1.187.35), libmbim-glib4:amd64 (1.24.8-
1~20.04, 1.26.2-1~ubuntu20.04.1), update-notifier:amd64 (,, xdg-desktop-portal:amd64 (1.6.0-1, 1.6.0-1ubunt
u2), libnotify4:amd64 (0.7.9-1ubuntu2, 0.7.9-1ubuntu3.20.04.2), python3-apt:amd64 (2.0.0ubuntu0.20.04.7, 2.0.1), base-files:amd64 (
11ubuntu5.5, 11ubuntu5.6)
End-Date: 2023-01-25  17:56:21

Start-Date: 2023-01-25  17:56:47
Commandline: aptdaemon role='role-commit-packages' sender=':1.931'
Install: libxmlb2:amd64 (0.3.6-2build1~20.04.1, automatic)
Upgrade: bolt:amd64 (0.8-4ubuntu1, 0.9.1-2~ubuntu20.04.1), update-manager-core:amd64 (1:, 1:, libwbclient0:a
md64 (2:4.13.17~dfsg-0ubuntu1.20.04.1, 2:4.13.17~dfsg-0ubuntu1.20.04.4), grub-common:amd64 (2.04-1ubuntu26.15, 2.04-1ubuntu26.16),
update-manager:amd64 (1:, 1:, dnsmasq-base:amd64 (2.80-1.1ubuntu1.5, 2.80-1.1ubuntu1.6), grub2-common:amd64
(2.04-1ubuntu26.15, 2.04-1ubuntu26.16), grub-pc:amd64 (2.04-1ubuntu26.15, 2.04-1ubuntu26.16), samba-libs:amd64 (2:4.13.17~dfsg-0ubu
ntu1.20.04.1, 2:4.13.17~dfsg-0ubuntu1.20.04.4), grub-pc-bin:amd64 (2.04-1ubuntu26.15, 2.04-1ubuntu26.16), apport:amd64 (2.20.11-0ub
untu27.24, 2.20.11-0ubuntu27.25), python3-update-manager:amd64 (1:, 1:, python3-apport:amd64 (2.20.11-0ubunt
u27.24, 2.20.11-0ubuntu27.25), libfwupdplugin5:amd64 (1.7.5-3~20.04.1, 1.7.9-1~20.04.1), distro-info-data:amd64 (0.43ubuntu1.10, 0.
43ubuntu1.11), libsmbclient:amd64 (2:4.13.17~dfsg-0ubuntu1.20.04.1, 2:4.13.17~dfsg-0ubuntu1.20.04.4), libfwupd2:amd64 (1.7.5-3~20.0
4.1, 1.7.9-1~20.04.1), libmysqlclient21:amd64 (8.0.31-0ubuntu0.20.04.1, 8.0.32-0buntu0.20.04.1), apport-gtk:amd64 (2.20.11-0ubuntu2
7.24, 2.20.11-0ubuntu27.25), fwupd:amd64 (1.7.5-3~20.04.1, 1.7.9-1~20.04.1), python3-tz:amd64 (2019.3-1, 2019.3-1ubuntu0.20.04.0),
python3-problem-report:amd64 (2.20.11-0ubuntu27.24, 2.20.11-0ubuntu27.25)
End-Date: 2023-01-25  17:56:56

(sorry for posting it here but I’m quite new to forums and did not know where to upload the info to link it here)

Oh yes OK, I forgot that. After the update within 20.04, after which the problem occurred first, it would have been interesting what packages. But of course upgrading to 22.04 changed everything, so that evidence is gone.

If the ifaces are up, I guess that’s fine. No idea, stabbing in the dark. All I know is that it works for other people on these versions :confused: Someone with Server on Linux could check if they get these Warn logs too, but I guess they wll

I did a quick scan of the logfiles on my roonserver on ubuntu server 22.02 (minimal), but did not see the “Warn: [multicastreceiver] couldn’t bind to iface …” log entries.
Is your firewall active? Maybe try to disable the firewall to see if the firewall is blocking some ports.

1 Like

Actually contrary to my previous reply on this, you should still be able to find the changes from the initial 20.04 update in the logs, just further down. Or they may have been rotated out by logrotate into history.1.log and so on

I am running 22.04 Sever and I don’t get these multicastreceiver warnings.

@Wolfgang_Vullhorst, what does the output of ip a show you? Are the ethernet and loopback devices multicast-enabled?

Edit: Better yet, please show the output of

sudo lshw -C network 
1 Like

Here are the outputs:

ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp88s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 54:b2:03:fd:44:70 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute enp88s0
       valid_lft 1515sec preferred_lft 1515sec
    inet6 fe80::aea8:9561:88ba:5b29/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether f0:9e:4a:8f:d6:30 brd ff:ff:ff:ff:ff:ff
    altname wlp0s20f3
sudo lshw -C network 

  *-network DISABLED
       description: Wireless interface
       product: Wi-Fi 6 AX201
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlo1
       version: 20
       serial: f0:9e:4a:8f:d6:30
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.15.0-58-generic firmware=66.f1c864e0.0 QuZ-a0-hr-b0-66.u latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: iomemory:600-5ff irq:19 memory:603d1a4000-603d1a7fff
       description: Ethernet interface
       product: Ethernet Controller I225-LM
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:58:00.0
       logical name: enp88s0
       version: 03
       serial: 54:b2:03:fd:44:70
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igc driverversion=5.15.0-58-generic duplex=full firmware=1057:8754 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:17 memory:6a200000-6a2fffff memory:6a300000-6a303fff

The interfaces are not up, the start is logged with “invalid argument” (see initial post).
Sorry, was a little misunderstandable in my first answer.

1 Like

I meant if the OS network interfaces as such are up. I.e., to rule out that the only cause for the log entries is just that the interfaces are down

To me that looks good. Both interfaces are up and the Ethernet interface is multicast-enabled, as is standard. But… your Roon core while starting up can’t bind its multicastreceiver component to the ethernet interface nor the loopback interface. I think it’s via this component that clients detect the Core server on the network, so that obviously fails.

I darkly remember having seen this before, but can’t recall how it was resolved. It’s as if Roon server wants to come up before the network interfaces are up… Have you tried to restart the Roon server on the running machine (sudo systemctl restart roonserver.service)?

I suppose you’ll have tried a reboot of the PC after upgrading…

So, asking Linux networking experts, what could possibly prevent Roon’s multicastreceiver component from binding to the local eth and loopback interfaces?

Edit: I know it’s a long shot, but are you using a network-connected Merging DAC?

Yes, no change.

Yes :slight_smile:

Sorry, I don’t know what that is… :smiley:
Connected devices are

  • Argon Audio SOLO
  • Pro-Ject Stream Box Ultra
  • Apple iPad, Macbook Pro, iPhone

Never mind, I just was remembering something similar caused by a Merging DAC driver on Windows…

Wouldn’t you prefer this thread moved to the forum’s Support category, to get more attention and hopefully official support?

I’m currently considering reinstalling the OS and Roon Server. Thx to all for your support, I will post an update here if the problem occurs again.

1 Like

This is what I would do… I guess it’ll be fine after a new installation. Please update here, even if all is fine after the reinstallation.

The Ethernet interface is up, but the ports aren’t bound. It’s a “bind” error, meaning the software (Roon Server) can’t bind to those ports to listen/broadcast. So, presumably, the other devices in the network can’t discover the Core.

I run Roon Core on a couple of Ubuntu Server 22.04 boxes. This vaguely rang a bell from when I first upgraded to 22.04 and got some issues with NetworkManager. I can’t recall the details and how I fixed the problem, but the “noprefixroute” flag on your IPv4 for enp88s0 may not be right. Here’s what my corresponding entry looks like:

2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:01:2e:96:4a:de brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic enp1s0
       valid_lft 82278sec preferred_lft 82278sec
    inet6 fe80::201:2eff:fe96:4ade/64 scope link 
       valid_lft forever preferred_lft forever

Searching for “noprefixroute” I got to the following quote:

  • noprefixroute: Do not create a route in the route table when this IP address is added. Someone has to add a route manually if he wants to use one with this IP address. Likewise, if this IP address is deleted, don’t look for a route to delete.

I think this is what I had to deal with when NetworkManager was not starting properly. Unfortunately I can’t recall what I did to make it work, but after that I’ve had no issues.

I see the same flag on the Ethernet interface of my 22.04 box which is working without any problem. This may not be the problem after all.

What I am thinking about is what would happen if any other software component listening for multicast packets had bound to the interface, before Roon’s multicastreceiver component comes up… Would this still work, with two or more listeners bound to the same interface, say on different ports?