UD-501 intermittently not allowing playback according to sample rate multiple

Roon Core Machine

Mac Mini running MacOS Monterey 12.4, M1 CPU, 8gb RAM.

Networking Gear & Setup Details


Connected Audio Devices

USB-A to B from Mac

Number of Tracks in Library

Around 2,000

Description of Issue

TEAC UD-501 running in exclusive mode with CoreAudio, will sometimes stop playing any track if it is of a certain base multiple. (Say it will play multiple of 48,000Hz, but not 44,100Hz, and will even do the reverse on other occasions).

Sometimes, usually when this happens on the initial launch of the Roon client, the issue will resolve itself if I play a track that is of the multiple it will allow to play first, then alternate back and forth afterwards.
However, lately it has been doing it constantly.

It’s important that I maintain exclusive mode, to get the best performance out of the system, but resolve this issue as well.

One thing worth mentioning. If upsampling is turned on for max PCM rate (power of 2), this issue does not seem to occur.
Just as much, I’d like to avoid being limited to always upsample as I prefer no digital filters end to end if possible.

I’ve tried several small tweaks, but am possibly missing something wildly simple here.
I’m open to any possibilities to resolve this without compromising sound performance.

Thank you!

See if there’s any software that may help from here:

You may also try Windows, or get new hardware.

It is previously discussed here:


Hi @Wayne_Jr,

Thank you for getting in touch, and welcome to Community! We’re happy to have you but sorry to see that it was an issue that prompted your first post. We’d be happy to help figure this out!

@wklie, pointed you in the right direction. To fix this issue, enable Max PCM upsampling in DSP engine. This will avoid sample rate changes during playback and should resolve your issue. Thanks!

1 Like

Thank you for the references!

As I’ve cited in my original post, I’ve been able to work around this by using the integrated upsampling DSP, but I’d prefer not to use it if I can avoid it.

In regards to the integer mode, I remember seeing that as a toggle option in advanced device settings.
Not sure if this can be switched in the ARM MacOS particularly, but I will investigate and report back.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.